]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub: Allow reautoconf with the correct parameters
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 23 Jul 2012 11:24:34 +0000 (11:24 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Jul 2012 09:11:54 +0000 (10:11 +0100)
Without this change, an effective reautoconf happens at compile time with potentially
incorrect parameters. This change ensures it happens once, in do_configure with the
correct parameters.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub_1.99.bb

index f1ed7ca6a5a52f5da09e98eed5a63b9eeabb068b..9879651dfb474054362d81fe51b7f57df9c63959 100644 (file)
@@ -37,10 +37,6 @@ inherit gettext
 
 EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="""
 
-do_configure() {
-    oe_runconf
-}
-
 do_install_append () {
     install -d ${D}${sysconfdir}/grub.d
     install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom