]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Don't change /usr/include references in docs to sysroot paths
authorOoi Cinly <cinly.ooi@intel.com>
Wed, 16 Aug 2017 01:18:26 +0000 (09:18 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Aug 2017 11:35:58 +0000 (12:35 +0100)
do_configure() will no longer convert references to
/usr/include into /path/to/recipes-sysroot/usr/include
for the file "Porting/Glossary".

[YOCTO #11243]

Signed-off-by: Ooi Cinly <cinly.ooi@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl_5.24.1.bb

index 95d96940052200d8b5ccaa9f21bf7983b3af0217..1e1d4f50fc4d3ddc460d7eb81c9e5a8ddb132619 100644 (file)
@@ -171,7 +171,7 @@ do_configure() {
                        ;;
        esac
         # These are strewn all over the source tree
-        for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" -m1 "/usr/include/.*\.h" ${S}/* -r -l` ${S}/utils/h2xs.PL ; do
+        for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" --exclude="Glossary" -m1 "/usr/include/.*\.h" ${S}/* -r -l` ${S}/utils/h2xs.PL ; do
             echo Fixing: $foo
             sed -e 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i $foo
         done