]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add usbinit hack to get usbnet connection on 770 (will replace with udev in due course)
authorRichard Purdie <richard@openedhand.com>
Wed, 28 Sep 2005 17:31:21 +0000 (17:31 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 28 Sep 2005 17:31:21 +0000 (17:31 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@53 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/oh/usbinit.bb [new file with mode: 0644]
openembedded/packages/oh/usbinit/usb-gether [new file with mode: 0755]

diff --git a/openembedded/packages/oh/usbinit.bb b/openembedded/packages/oh/usbinit.bb
new file mode 100644 (file)
index 0000000..bfc8490
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Quick hack to start gadget Ethernet on the 770"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "file://usb-gether"
+S = ${WORKDIR}
+
+do_install() {
+    install -d ${D}/etc
+    install -d ${D}/etc/init.d
+    install usb-gether ${D}/etc/init.d
+}    
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "usb-gether"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
diff --git a/openembedded/packages/oh/usbinit/usb-gether b/openembedded/packages/oh/usbinit/usb-gether
new file mode 100755 (executable)
index 0000000..590e77b
--- /dev/null
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+case "$1" in
+  start)
+    /sbin/depmod -a
+    /sbin/modprobe g_ether
+    ifconfig usb0 192.168.1.120
+  ;;
+
+  stop)
+    
+  ;;
+
+  *)
+        echo "usage: $0 { start | stop }"
+  ;;
+esac
+
+exit 0