]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: Drop unneeded custom staging functions
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 17 Nov 2009 14:23:25 +0000 (14:23 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 17 Nov 2009 14:23:25 +0000 (14:23 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/freetype/freetype-native_2.3.5.bb
meta/packages/freetype/freetype_2.3.5.bb

index a241741ab275064ea180fbf79f3cb890f37aff84..f44ca4b55fb8059689299cb4cd86de395bf0bd11 100644 (file)
@@ -7,9 +7,3 @@ do_configure() {
        (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
        oe_runconf
 }
-
-do_stage() {
-       autotools_stage_includes
-       oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
-}
-
index e8dc6c1d43cdf8af9a2cec2429e0f8ef983af6c8..f5934bd662986358265827a7f7449b4e7bfb703d 100644 (file)
@@ -30,11 +30,5 @@ do_compile_prepend() {
        ${BUILD_CC} -o objs/apinames src/tools/apinames.c
 }
 
-do_stage() {
-     export LIBTOOL='${LIBTOOL}'
-        autotools_stage_all
-        oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
-}
-
 FILES_${PN} = "${libdir}/lib*${SOLIBS}"
 FILES_${PN}-dev += "${bindir}"