]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash (GPLv2): remove metadata sharing from GPLv3 recipe
authorKevin Tian <kevin.tian@intel.com>
Tue, 24 Aug 2010 07:34:35 +0000 (15:34 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:04:38 +0000 (13:04 +0100)
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/packages/bash/bash_3.2.48.bb

index 47afe98801f6453816f87e36f714eb4c4110ce8a..ee563d626a5ab5efa1148ff6f34b47fb154898e4 100644 (file)
@@ -1,11 +1,35 @@
-require bash.inc
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+SECTION = "base/shell"
 
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
+DEPENDS = "ncurses"
+
 PR = "r6"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
            http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0 \
            http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-050;apply=yes;striplevel=0 \
-           http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-051;apply=yes;striplevel=0 \
-           "
+           http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-051;apply=yes;striplevel=0"
+
+inherit autotools gettext
+
+PARALLEL_MAKE = ""
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-ncurses"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+       gnu-configize
+       oe_runconf
+}
+
+pkg_postinst () {
+       touch $D${sysconfdir}/shells
+       grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
+       grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
+}