]> code.ossystems Code Review - openembedded-core.git/commitdiff
nativesdk-buildtools-perl-dummy.bb: Fix variable expansion in python code
authorAníbal Limón <anibal.limon@linux.intel.com>
Thu, 11 Feb 2016 22:08:06 +0000 (16:08 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Feb 2016 22:33:21 +0000 (22:33 +0000)
Since python expansion of bb data variables is disable in order to
provide a standard interface usage for expand variables this variables
aren't expanded now so change to call d.expand('${VAR}').

This API expansion change was causing to install perl in nativesdk.

Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb

index 9041734898ea2fbd5c9f40b941bec660773606c3..90784a9e27ce0f6607c61b191799f64b987d3890 100644 (file)
@@ -20,7 +20,7 @@ PERLPACKAGES = "nativesdk-perl \
 ALLOW_EMPTY_${PN} = "1"
 
 python populate_packages_prepend() {
-    d.appendVar('RPROVIDES_${PN}', '${PERLPACKAGES}')
-    d.appendVar('RCONFLICTS_${PN}', '${PERLPACKAGES}')
+    d.appendVar(d.expand('RPROVIDES_${PN}'), '${PERLPACKAGES}')
+    d.appendVar(d.expand('RCONFLICTS_${PN}'), '${PERLPACKAGES}')
 }