]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-toolchain: Add version data to the sdk tarballs
authorRichard Purdie <richard@openedhand.com>
Fri, 15 Feb 2008 17:29:40 +0000 (17:29 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 15 Feb 2008 17:29:40 +0000 (17:29 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3820 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/meta-toolchain.bb

index fb213b88b51b0c88f2b95d54b9f6487ea2d795ca..525d090916dfe4e36e82f33f68bbb1ad791f7d62 100644 (file)
@@ -123,6 +123,14 @@ do_populate_sdk() {
        echo 'export PKG_CONFIG_PATH=${prefix}/${TARGET_SYS}/lib/pkgconfig' >> $script
        echo 'export CONFIG_SITE=${prefix}/site-config' >> $script
 
+       # Add version information
+       versionfile=${SDK_OUTPUT}/${prefix}/version
+       touch $versionfile
+       echo 'Distro: ${DISTRO}' >> $versionfile
+       echo 'Distro Version: ${DISTRO_VERSION}' >> $versionfile
+       echo 'Metadata Revision: ${METADATA_REVISION}' >> $versionfile
+       echo 'Timestamp: ${DATETIME}' >> $versionfile
+
        # Package it up
        mkdir -p ${SDK_DEPLOY}
        cd ${SDK_OUTPUT}