]> code.ossystems Code Review - openembedded-core.git/commitdiff
puzzles: Fix build with clang
authorKhem Raj <raj.khem@gmail.com>
Mon, 7 Sep 2015 09:06:10 +0000 (09:06 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 12 Sep 2015 21:47:17 +0000 (22:47 +0100)
Clang uncovered an error where abs() is used on long types, we shoud be
using labs()

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-sato/puzzles/files/0001-Use-labs-instead-of-abs.patch [new file with mode: 0644]
meta/recipes-sato/puzzles/puzzles_git.bb

diff --git a/meta/recipes-sato/puzzles/files/0001-Use-labs-instead-of-abs.patch b/meta/recipes-sato/puzzles/files/0001-Use-labs-instead-of-abs.patch
new file mode 100644 (file)
index 0000000..f43d1df
--- /dev/null
@@ -0,0 +1,46 @@
+From 9808dc09e08937c9bffd858d3ded428225a4312a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 7 Sep 2015 09:02:38 +0000
+Subject: [PATCH] Use labs instead of abs
+
+cluevals is array of longs so we have to use labs() instead of abs()
+since abs() returns int
+
+Fixes
+
+keen.c:1458:17: error: absolute value function 'abs' given an argument
+of type 'long' but has parameter of type 'int' which may cause
+truncation of value
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ keen.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/keen.c b/keen.c
+index a6a7238..1631992 100644
+--- a/keen.c
++++ b/keen.c
+@@ -1043,7 +1043,7 @@ done
+                   cluevals[j] *= grid[i];
+                   break;
+                 case C_SUB:
+-                  cluevals[j] = abs(cluevals[j] - grid[i]);
++                  cluevals[j] = labs(cluevals[j] - grid[i]);
+                   break;
+                 case C_DIV:
+                   {
+@@ -1455,7 +1455,7 @@ static int check_errors(const game_state *state, long *errors)
+               cluevals[j] *= state->grid[i];
+               break;
+             case C_SUB:
+-              cluevals[j] = abs(cluevals[j] - state->grid[i]);
++              cluevals[j] = labs(cluevals[j] - state->grid[i]);
+               break;
+             case C_DIV:
+               {
+-- 
+2.5.1
+
index 11e922511ce40f5308db61f88a83df7140ac8344..95826c1b60d0b79bf566476842b446ad728bd843 100644 (file)
@@ -11,6 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
 
 SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
            file://fix-compiling-failure-with-option-g-O.patch \
+           file://0001-Use-labs-instead-of-abs.patch \
 "
 SRCREV = "c296301a06ce49b87c954c9d15452521dfeddf1a"
 PE = "1"