]> code.ossystems Code Review - openembedded-core.git/commitdiff
oeqa/selftest: lock down Meson git revision for reliability
authorRoss Burton <ross.burton@intel.com>
Mon, 5 Jun 2017 16:30:42 +0000 (17:30 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Jun 2017 16:59:29 +0000 (17:59 +0100)
The test_recipetool_create_github test fetches HEAD of the repository so
upstream changes can (and do) break the test.  Avoid these problems by passing
the rev= argument in the URL to lock the checkout to the same version that is
fetched in the github_tarball test.

Also pass the commands to runCmd() as a list instead of a string, the semicolon
in the URL needs more quotes if the shell is involved and passing a list
bypasses the shell entirely.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/selftest/recipetool.py

index c3d618ff851a79473cf8ebfe620600d05fbd204b..9b669248f6ffa34ba6b195d88200e6019aba0984 100644 (file)
@@ -442,8 +442,8 @@ class RecipetoolTests(RecipetoolBase):
         temprecipe = os.path.join(self.tempdir, 'recipe')
         os.makedirs(temprecipe)
         recipefile = os.path.join(temprecipe, 'meson_git.bb')
-        srcuri = 'https://github.com/mesonbuild/meson'
-        result = runCmd('recipetool create -o %s %s' % (temprecipe, srcuri))
+        srcuri = 'https://github.com/mesonbuild/meson;rev=0.32.0'
+        result = runCmd(['recipetool', 'create', '-o', temprecipe, srcuri])
         self.assertTrue(os.path.isfile(recipefile))
         checkvars = {}
         checkvars['LICENSE'] = set(['Apache-2.0'])