]> code.ossystems Code Review - openembedded-core.git/commitdiff
gawk: Enable native building
authorNathan Rossi <nathan@nathanrossi.com>
Sun, 10 Sep 2017 12:59:08 +0000 (22:59 +1000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Sep 2017 10:07:24 +0000 (11:07 +0100)
Also update the ASSUME_PROVIDED in bitbake.conf to contain gawk-native
as the dependency is passed in via HOSTTOOLS for native builds.

This allows for recipes to depend on gawk-native, and have the
dependency met if not already provided by the host tools.

Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/conf/bitbake.conf
meta/recipes-extended/gawk/gawk_4.1.4.bb

index 8fb596e6b9d1a49d3918496642d4d2ef8085606e..4ff1e9608e7929353dd5b2fc8a1581da30c8859c 100644 (file)
@@ -176,6 +176,7 @@ ASSUME_PROVIDED = "\
     chrpath-native \
     file-native \
     findutils-native \
+    gawk-native \
     git-native \
     grep-native \
     diffstat-native \
index dda38ef1bb22f7d572029c6ad0132136d1848d17..04451f7ff8ec26edd26fd13db6b5e225320ce376 100644 (file)
@@ -46,4 +46,4 @@ do_install_ptest() {
        done
 }
 
-BBCLASSEXTEND = "nativesdk"
+BBCLASSEXTEND = "native nativesdk"