]> code.ossystems Code Review - openembedded-core.git/commitdiff
cve-update-db-native: be less magical about checking whether the cve-check class...
authorChris Laplante <chris.laplante@agilent.com>
Mon, 14 Sep 2020 15:33:18 +0000 (11:33 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Sep 2020 21:44:49 +0000 (22:44 +0100)
Signed-off-by: Chris Laplante <chris.laplante@agilent.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/cve-update-db-native.bb

index e4e2451bfd3c158fda908c16b97704630b0b63dd..c2f713312f338246d718a666639b5c87c235c119 100644 (file)
@@ -13,8 +13,7 @@ deltask do_install
 deltask do_populate_sysroot
 
 python () {
-    cve_check_db_file = d.getVar("CVE_CHECK_DB_FILE")
-    if not cve_check_db_file:
+    if not bb.data.inherits_class("cve-check", d):
         raise bb.parse.SkipRecipe("Skip recipe when cve-check class is not loaded.")
 
     if os.path.exists("%s-journal" % cve_check_db_file ):