]> code.ossystems Code Review - openembedded-core.git/commitdiff
oeqa/selftest/recipetool: actually fix create_github test
authorRoss Burton <ross.burton@intel.com>
Wed, 7 Jun 2017 14:28:24 +0000 (15:28 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Jun 2017 14:58:55 +0000 (15:58 +0100)
The Meson revision was locked down but the license list change wasn't actually
committed...

Also specify the exact path for recipetool to write to, for clarity.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/selftest/recipetool.py

index 312684be27b5bbf6efbaed779b8355e0912d9fc2..0ec838165593737cf3f01d4c98bb601cae26ce84 100644 (file)
@@ -448,10 +448,10 @@ class RecipetoolTests(RecipetoolBase):
         os.makedirs(temprecipe)
         recipefile = os.path.join(temprecipe, 'meson_git.bb')
         srcuri = 'https://github.com/mesonbuild/meson;rev=0.32.0'
-        result = runCmd(['recipetool', 'create', '-o', temprecipe, srcuri])
+        result = runCmd(['recipetool', 'create', '-o', recipefile, srcuri])
         self.assertTrue(os.path.isfile(recipefile))
         checkvars = {}
-        checkvars['LICENSE'] = set(['Apache-2.0', 'Unknown'])
+        checkvars['LICENSE'] = set(['Apache-2.0'])
         checkvars['SRC_URI'] = 'git://github.com/mesonbuild/meson;protocol=https'
         inherits = ['setuptools']
         self._test_recipe_contents(recipefile, checkvars, inherits)