]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: upgrade to version 158
authorQing He <qing.he@intel.com>
Wed, 21 Jul 2010 05:34:35 +0000 (13:34 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 23 Jul 2010 23:07:30 +0000 (00:07 +0100)
older versions are kept untouched for now

changes:
  - udev has diverged a lot, the udev.inc was based on a quite dated
    version, thus doesn't reflect current status of udev, create a
    new include file udev-new.inc to adapt
  - separate libudev{,-dev,-dbg} apart from udev
  - --with-udev-prefix is removed. change ${libexecdir} to
    ${base_libdir}/udev, which is described in INSTALL file.
  - udev.pc is provided in ${datadir}/pkgconfig, since it's used
    to indicate the existence of udev itself instead of development
    headers and libs, pack it in udev instead of udev-dev
  - udev-extras is disabled since we are missing libacl, this also
    means gudev is missing as for now
  - other cleanups, e.g. do_stage, do_install, EXTRA_OEMAKE

todo:
  - udev-extras
  - remove old udev versions
  - rebase udev-145 on udev-new.inc as well

Signed-off-by: Qing He <qing.he@intel.com>
meta/conf/distro/include/poky-fixed-revisions.inc
meta/packages/udev/udev-158/init [new file with mode: 0644]
meta/packages/udev/udev-158/local.rules [new file with mode: 0644]
meta/packages/udev/udev-158/permissions.rules [new file with mode: 0644]
meta/packages/udev/udev-158/run.rules [new file with mode: 0644]
meta/packages/udev/udev-158/udev.rules [new file with mode: 0644]
meta/packages/udev/udev-new.inc [new file with mode: 0644]
meta/packages/udev/udev_158.bb [new file with mode: 0644]

index 081a59ab99bd04b4330053a55f0184003056c036..9606745d55e07ab2b4d1ced5baa46cac8397bb0d 100644 (file)
@@ -26,7 +26,7 @@ PREFERRED_VERSION_oprofile ?= "0.9.6"
 PREFERRED_VERSION_elfutils ?= "0.89"
 PREFERRED_VERSION_hal ?= "0.5.14"
 PREFERRED_VERSION_hal-info ?= "20091130"
-PREFERRED_VERSION_udev ?= "141"
+PREFERRED_VERSION_udev ?= "158"
 
 
 #
diff --git a/meta/packages/udev/udev-158/init b/meta/packages/udev/udev-158/init
new file mode 100644 (file)
index 0000000..eb5e507
--- /dev/null
@@ -0,0 +1,59 @@
+#!/bin/sh -e
+
+### BEGIN INIT INFO
+# Provides:          udev
+# Required-Start:    mountvirtfs
+# Required-Stop:     
+# Default-Start:     S
+# Default-Stop:
+# Short-Description: Start udevd, populate /dev and load drivers.
+### END INIT INFO
+
+export TZ=/etc/localtime
+
+[ -d /sys/class ] || exit 1
+[ -r /proc/mounts ] || exit 1
+[ -x /sbin/udevd ] || exit 1
+[ -f /etc/udev/udev.conf ] && . /etc/udev/udev.conf
+
+kill_udevd() {
+        if [ -x /sbin/pidof ]; then
+                pid=`/sbin/pidof -x udevd`
+                [ -n "$pid" ] && kill $pid
+        fi
+}
+
+export ACTION=add
+# propagate /dev from /sys
+echo -n "Starting udev"
+
+# mount the tmpfs on /dev, if not already done
+LANG=C awk "\$2 == \"/dev\" && \$4 == \"tmpfs\" { exit 1 }" /proc/mounts && {
+        mount -n -o mode=0755 -t tmpfs none "/dev"
+        mkdir -m 0755 /dev/pts
+        mkdir -m 1777 /dev/shm
+}
+
+if [ -e /etc/dev.tar ]; then
+       (cd /; tar xf /etc/dev.tar)
+       not_first_boot=1
+fi
+
+# make_extra_nodes
+kill_udevd > "/dev/null" 2>&1
+
+        # trigger the sorted events
+        echo -e '\000\000\000\000' > /proc/sys/kernel/hotplug
+        /sbin/udevd -d
+
+        /sbin/udevadm control --env=STARTUP=1
+               if [ "$not_first_boot" != "" ];then
+                       /sbin/udevadm trigger --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus  --subsystem-nomatch=graphics  --subsystem-nomatch=backlight --subsystem-nomatch=video4linux  --subsystem-nomatch=platform
+                       (/sbin/udevadm settle --timeout=3; /sbin/udevadm control --env=STARTUP=)&
+               else
+                       /sbin/udevadm trigger
+                       /sbin/udevadm settle
+               fi
+
+echo
+exit 0
diff --git a/meta/packages/udev/udev-158/local.rules b/meta/packages/udev/udev-158/local.rules
new file mode 100644 (file)
index 0000000..dab319b
--- /dev/null
@@ -0,0 +1,33 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+#    For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Media automounting
+SUBSYSTEM=="block", ACTION=="add"    RUN+="/etc/udev/scripts/mount.sh"
+SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
+
+# Handle network interface setup
+SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
+SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
+
+# The first rtc device is symlinked to /dev/rtc
+KERNEL=="rtc0", SYMLINK+="rtc"
+
+# Try and modprobe for drivers for new hardware
+ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
+
+# Create a symlink to any touchscreen input device
+# Need to use ../ so the eventX can find the parent inputX modalias which is a directory above
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{../modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
+
diff --git a/meta/packages/udev/udev-158/permissions.rules b/meta/packages/udev/udev-158/permissions.rules
new file mode 100644 (file)
index 0000000..205b733
--- /dev/null
@@ -0,0 +1,131 @@
+ACTION!="add", GOTO="permissions_end"
+
+# workarounds needed to synchronize with sysfs
+# only needed for kernels < v2.6.18-rc1
+ENV{PHYSDEVPATH}!="?*", ENV{PHYSDEVBUS}=="?*", WAIT_FOR_SYSFS="bus"
+SUBSYSTEM=="scsi", KERNEL=="[0-9]*:[0-9]*",    WAIT_FOR_SYSFS="ioerr_cnt"
+# only needed for kernels < 2.6.16
+SUBSYSTEM=="net",                              WAIT_FOR_SYSFS="address"
+# only needed for kernels < 2.6.17
+SUBSYSTEM=="net", ENV{DRIVER}=="?*",           WAIT_FOR_SYSFS="device/driver"
+
+# devices needed to load the drivers providing them
+KERNEL=="tun",                                 OPTIONS+="ignore_remove"
+KERNEL=="ppp",                                 OPTIONS+="ignore_remove"
+KERNEL=="loop[0-9]*",                          OPTIONS+="ignore_remove"
+
+# default permissions for block devices
+SUBSYSTEM=="block",                            GROUP="disk"
+# the aacraid driver is broken and reports that disks removable (see #404927)
+SUBSYSTEM=="block", ATTRS{removable}=="1", \
+       DRIVERS!="aacraid",                     GROUP="floppy"
+# all block devices on these buses are "removable"
+SUBSYSTEM=="block", SUBSYSTEMS=="usb|ieee1394|mmc|pcmcia", GROUP="floppy"
+
+# IDE devices
+KERNEL=="hd[a-z]|pcd[0-9]*",                   DRIVERS=="ide-cdrom|pcd", \
+       IMPORT{program}="cdrom_id --export $tempnode"
+ENV{ID_CDROM}=="?*",                           GROUP="cdrom"
+KERNEL=="ht[0-9]*",                            GROUP="tape"
+KERNEL=="nht[0-9]*",                           GROUP="tape"
+
+# SCSI devices
+KERNEL=="sr[0-9]*", IMPORT{program}="cdrom_id --export $tempnode"
+SUBSYSTEMS=="scsi", ATTRS{type}=="1",                          GROUP="tape"
+SUBSYSTEMS=="scsi", ATTRS{type}=="3", ATTRS{vendor}=="HP",     GROUP="scanner"
+SUBSYSTEMS=="scsi", ATTRS{type}=="3", ATTRS{vendor}=="Epson",  GROUP="scanner"
+SUBSYSTEMS=="scsi", ATTRS{type}=="3", ATTRS{vendor}=="EPSON",  GROUP="scanner"
+SUBSYSTEMS=="scsi", ATTRS{type}=="4",                          GROUP="cdrom"
+SUBSYSTEMS=="scsi", ATTRS{type}=="5",                          GROUP="cdrom"
+SUBSYSTEMS=="scsi", ATTRS{type}=="6",                          GROUP="scanner"
+SUBSYSTEMS=="scsi", ATTRS{type}=="8",                          GROUP="tape"
+
+# USB devices
+KERNEL=="legousbtower*",       MODE="0666"
+KERNEL=="lp[0-9]*", SUBSYSTEMS=="usb",         GROUP="lp"
+
+# usbfs-like devices
+SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", \
+                               MODE="0664"
+
+# iRiver music players
+SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device",  GROUP="plugdev", \
+       ATTRS{idVendor}=="4102", ATTRS{idProduct}=="10[01][135789]"
+
+# serial devices
+SUBSYSTEM=="tty",                              GROUP="dialout"
+SUBSYSTEM=="capi",                             GROUP="dialout"
+SUBSYSTEM=="slamr",                            GROUP="dialout"
+SUBSYSTEM=="zaptel",                           GROUP="dialout"
+
+# vc devices (all members of the tty subsystem)
+KERNEL=="ptmx",                        MODE="0666",    GROUP="root"
+KERNEL=="console",             MODE="0600",    GROUP="root"
+KERNEL=="tty",                 MODE="0666",    GROUP="root"
+KERNEL=="tty[0-9]*",                           GROUP="root"
+KERNEL=="pty*",                        MODE="0666",    GROUP="tty"
+
+# video devices
+SUBSYSTEM=="video4linux",                      GROUP="video"
+SUBSYSTEM=="drm",                              GROUP="video"
+SUBSYSTEM=="dvb",                              GROUP="video"
+SUBSYSTEM=="em8300",                           GROUP="video"
+SUBSYSTEM=="graphics",                         GROUP="video"
+SUBSYSTEM=="nvidia",                           GROUP="video"
+
+# misc devices
+KERNEL=="random",              MODE="0666"
+KERNEL=="urandom",             MODE="0666"
+KERNEL=="mem",                 MODE="0640",    GROUP="kmem"
+KERNEL=="kmem",                        MODE="0640",    GROUP="kmem"
+KERNEL=="port",                        MODE="0640",    GROUP="kmem"
+KERNEL=="full",                        MODE="0666"
+KERNEL=="null",                        MODE="0666"
+KERNEL=="zero",                        MODE="0666"
+KERNEL=="inotify",             MODE="0666"
+KERNEL=="sgi_fetchop",         MODE="0666"
+KERNEL=="sonypi",              MODE="0666"
+KERNEL=="agpgart",                             GROUP="video"
+KERNEL=="nvram",                               GROUP="nvram"
+KERNEL=="rtc|rtc[0-9]*",                       GROUP="audio"
+KERNEL=="tpm*",                        MODE="0600",    OWNER="tss", GROUP="tss"
+KERNEL=="fuse",                                        GROUP="fuse"
+KERNEL=="kqemu",               MODE="0666"
+KERNEL=="kvm",                                 GROUP="kvm"
+KERNEL=="tun",                 MODE="0666",
+
+KERNEL=="cdemu[0-9]*",                         GROUP="cdrom"
+KERNEL=="pktcdvd[0-9]*",                       GROUP="cdrom"
+KERNEL=="pktcdvd",             MODE="0644"
+
+KERNEL=="uverbs*",                             GROUP="rdma"
+KERNEL=="ucm*",                                        GROUP="rdma"
+KERNEL=="rdma_ucm",                            GROUP="rdma"
+
+# printers and parallel devices
+SUBSYSTEM=="printer",                          GROUP="lp"
+SUBSYSTEM=="ppdev",                            GROUP="lp"
+KERNEL=="irlpt*",                              GROUP="lp"
+KERNEL=="pt[0-9]*",                            GROUP="tape"
+KERNEL=="pht[0-9]*",                           GROUP="tape"
+
+# sound devices
+SUBSYSTEM=="sound",                            GROUP="audio"
+
+# ieee1394 devices       
+KERNEL=="raw1394",                             GROUP="disk"
+KERNEL=="dv1394*",                             GROUP="video"
+KERNEL=="video1394*",                          GROUP="video"
+
+# input devices
+KERNEL=="event[0-9]*", ATTRS{name}=="*dvb*|*DVB*|* IR *" \
+                               MODE="0664",    GROUP="video"
+KERNEL=="js[0-9]*",            MODE="0664"
+KERNEL=="lirc[0-9]*",                          GROUP="video"
+
+# AOE character devices
+SUBSYSTEM=="aoe",              MODE="0220",    GROUP="disk"
+SUBSYSTEM=="aoe", KERNEL=="err", MODE="0440"
+
+LABEL="permissions_end"
+
diff --git a/meta/packages/udev/udev-158/run.rules b/meta/packages/udev/udev-158/run.rules
new file mode 100644 (file)
index 0000000..75d7137
--- /dev/null
@@ -0,0 +1,14 @@
+# debugging monitor
+RUN+="socket:/org/kernel/udev/monitor"
+
+# run a command on remove events
+ACTION=="remove", ENV{REMOVE_CMD}!="", RUN+="$env{REMOVE_CMD}"
+
+# ignore the events generated by virtual consoles
+KERNEL=="ptmx",                OPTIONS+="last_rule"
+KERNEL=="console",     OPTIONS+="last_rule"
+KERNEL=="tty"  ,       OPTIONS+="last_rule"
+KERNEL=="tty[0-9]*",   OPTIONS+="last_rule"
+KERNEL=="pty*",                OPTIONS+="last_rule"
+SUBSYSTEM=="vc",       OPTIONS+="last_rule"
+
diff --git a/meta/packages/udev/udev-158/udev.rules b/meta/packages/udev/udev-158/udev.rules
new file mode 100644 (file)
index 0000000..a19d4a0
--- /dev/null
@@ -0,0 +1,116 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+#    For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# workaround for devices which do not report media changes
+SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", ATTR{removable}=="1", \
+       ENV{ID_MODEL}=="IOMEGA_ZIP*",   NAME="%k", OPTIONS+="all_partitions"
+SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", ATTRS{media}=="floppy", \
+       OPTIONS+="all_partitions"
+
+# SCSI devices
+SUBSYSTEMS=="scsi", KERNEL=="sr[0-9]*",        NAME="scd%n", SYMLINK+="sr%n"
+
+# USB devices
+SUBSYSTEMS=="usb", KERNEL=="auer[0-9]*",       NAME="usb/%k"
+SUBSYSTEMS=="usb", KERNEL=="cpad[0-9]*",       NAME="usb/%k"
+SUBSYSTEMS=="usb", KERNEL=="dabusb*",          NAME="usb/%k"
+SUBSYSTEMS=="usb", KERNEL=="hiddev*",          NAME="usb/%k"
+SUBSYSTEMS=="usb", KERNEL=="legousbtower*",    NAME="usb/%k"
+SUBSYSTEMS=="usb", KERNEL=="lp[0-9]*",         NAME="usb/%k"
+SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", \
+       ATTRS{product}=="Palm Handheld*|Handspring Visor|palmOne Handheld", \
+                                       SYMLINK+="pilot"
+
+# usbfs-like devices
+SUBSYSTEM=="usb_device",       PROGRAM="/bin/sh -c 'K=%k; K=$${K#usbdev}; printf bus/usb/%%03i/%%03i $${K%%%%.*} $${K#*.}'", ACTION=="add", \
+                               NAME="%c"
+SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device",  NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}"
+
+# serial devices
+KERNEL=="capi",                        NAME="capi20", SYMLINK+="isdn/capi20"
+KERNEL=="capi[0-9]*",          NAME="capi/%n"
+
+# video devices
+KERNEL=="dvb*",                        PROGRAM="/bin/sh -c 'K=%k; K=$${K#dvb}; printf dvb/adapter%%i/%%s $${K%%%%.*} $${K#*.}", ACTION=="add", \
+                               NAME="%c"
+KERNEL=="card[0-9]*",          NAME="dri/%k"
+
+# misc devices
+KERNEL=="hw_random",           NAME="hwrng"
+KERNEL=="tun",                 NAME="net/%k"
+KERNEL=="evtchn",              NAME="xen/%k"
+
+KERNEL=="cdemu[0-9]*",         NAME="cdemu/%n"
+KERNEL=="pktcdvd[0-9]*",       NAME="pktcdvd/%n"
+KERNEL=="pktcdvd",             NAME="pktcdvd/control"
+
+KERNEL=="cpu[0-9]*",           NAME="cpu/%n/cpuid"
+KERNEL=="msr[0-9]*",           NAME="cpu/%n/msr"
+KERNEL=="microcode",           NAME="cpu/microcode"
+
+KERNEL=="umad*",               NAME="infiniband/%k"
+KERNEL=="issm*",               NAME="infiniband/%k"
+KERNEL=="uverbs*",             NAME="infiniband/%k"
+KERNEL=="ucm*",                        NAME="infiniband/%k"
+KERNEL=="rdma_ucm",            NAME="infiniband/%k"
+
+# ALSA devices
+KERNEL=="controlC[0-9]*",      NAME="snd/%k"
+KERNEL=="hwC[D0-9]*",          NAME="snd/%k"
+KERNEL=="pcmC[D0-9cp]*",       NAME="snd/%k"
+KERNEL=="midiC[D0-9]*",                NAME="snd/%k"
+KERNEL=="timer",               NAME="snd/%k"
+KERNEL=="seq",                 NAME="snd/%k"
+
+# ieee1394 devices       
+KERNEL=="dv1394*",             NAME="dv1394/%n"
+KERNEL=="video1394*",          NAME="video1394/%n"
+
+# input devices
+KERNEL=="mice",                        NAME="input/%k"
+KERNEL=="mouse[0-9]*",         NAME="input/%k"
+KERNEL=="event[0-9]*",         NAME="input/%k"
+KERNEL=="js[0-9]*",            NAME="input/%k"
+KERNEL=="ts[0-9]*",            NAME="input/%k"
+KERNEL=="uinput",              NAME="input/%k"
+
+# Zaptel
+KERNEL=="zapctl",              NAME="zap/ctl"
+KERNEL=="zaptimer",            NAME="zap/timer"
+KERNEL=="zapchannel",          NAME="zap/channel"
+KERNEL=="zappseudo",           NAME="zap/pseudo"
+KERNEL=="zap[0-9]*",           NAME="zap/%n"
+
+# AOE character devices
+SUBSYSTEM=="aoe", KERNEL=="discover",  NAME="etherd/%k"
+SUBSYSTEM=="aoe", KERNEL=="err",       NAME="etherd/%k"
+SUBSYSTEM=="aoe", KERNEL=="interfaces",        NAME="etherd/%k"
+SUBSYSTEM=="aoe", KERNEL=="revalidate",        NAME="etherd/%k"
+
+# device mapper creates its own device nodes, so ignore these
+KERNEL=="dm-[0-9]*",           OPTIONS+="ignore_device"
+KERNEL=="device-mapper",       NAME="mapper/control"
+
+KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
+
+# Firmware Helper
+ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
+
+# Samsung UARTS
+KERNEL=="s3c2410_serial[0-9]",   NAME="ttySAC%n"
+
+# MXC UARTs
+KERNEL=="ttymxc[0-4]",   NAME="ttymxc%n"
+
diff --git a/meta/packages/udev/udev-new.inc b/meta/packages/udev/udev-new.inc
new file mode 100644 (file)
index 0000000..de02b23
--- /dev/null
@@ -0,0 +1,87 @@
+DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
+/dev/, handles hotplug events and loads drivers at boot time. It replaces \
+the hotplug package and requires a kernel not older than 2.6.12."
+HOMEPAGE = "http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+LICENSE = "GPLv2+ & LGPLv2.1+"
+LICENSE_${PN} = "GPLv2+"
+LICENSE_libudev = "LGPLv2.1+"
+#LICENSE_libgudev = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+                    file://libudev/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+                    file://extras/gudev/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+# the following dependency is needed for udev-extras
+#DEPENDS = "libacl glib-2.0 libusb usbutils pciutils linux-libc-headers gperf-native"
+RPROVIDES_${PN} = "hotplug"
+RRECOMMENDS_${PN} += "udev-extraconf udev-cache"
+
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
+           file://run.rules \
+           file://udev.rules \
+           file://devfs-udev.rules \
+           file://links.conf \
+           file://permissions.rules \
+           file://mount.sh \
+           file://network.sh \
+           file://local.rules \
+           file://udev-cache \
+           file://init"
+
+SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
+
+inherit autotools pkgconfig update-rc.d
+
+# udevd/udevadm -> /sbin/, libudev.so.* -> /lib/
+sbindir = "${base_sbindir}"
+libexecdir = "${base_libdir}/udev"
+EXTRA_OECONF = "--disable-extras --disable-introspection --with-rootlibdir=${base_libdir}"
+
+PACKAGES =+ "udev-cache libudev libudev-dev libudev-dbg"
+PACKAGE_ARCH_h2200 = "h2200"
+
+INITSCRIPT_PACKAGES = "udev udev-cache"
+INITSCRIPT_NAME_udev = "udev"
+INITSCRIPT_PARAMS_udev = "start 04 S ."
+INITSCRIPT_NAME_udev-cache = "udev-cache"
+INITSCRIPT_PARAMS_udev-cache = "start 36 S ."
+
+FILES_${PN} += "${libexecdir} ${datadir}/pkgconfig/udev.pc"
+FILES_${PN}-dbg += "${libexecdir}/.debug"
+FILES_${PN}-dev = ""
+FILES_libudev = "${base_libdir}/libudev.so.*"
+FILES_libudev-dbg = "${base_libdir}/.debug/libudev.so.*"
+FILES_libudev-dev = "${includedir}/libudev.h ${libdir}/libudev.so ${libdir}/libudev.la \
+                     ${libdir}/libudev.a ${libdir}/pkgconfig/libudev.pc"
+FILES_udev-cache = "${sysconfdir}/init.d/udev-cache"
+
+
+do_install_append () {
+       install -d ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
+       install -m 0755 ${WORKDIR}/udev-cache ${D}${sysconfdir}/init.d/udev-cache
+
+       install -d ${D}${sysconfdir}/udev/rules.d/
+
+       install -m 0644 ${WORKDIR}/local.rules         ${D}${sysconfdir}/udev/rules.d/local.rules
+       #install -m 0644 ${WORKDIR}/permissions.rules   ${D}${sysconfdir}/udev/rules.d/permissions.rules
+       #install -m 0644 ${WORKDIR}/run.rules          ${D}${sysconfdir}/udev/rules.d/run.rules
+       #install -m 0644 ${WORKDIR}/udev.rules          ${D}${sysconfdir}/udev/rules.d/udev.rules
+       install -m 0644 ${WORKDIR}/links.conf          ${D}${sysconfdir}/udev/links.conf
+       #if [ "${UDEV_DEVFS_RULES}" = "1" ]; then
+       #       install -m 0644 ${WORKDIR}/devfs-udev.rules ${D}${sysconfdir}/udev/rules.d/devfs-udev.rules
+       #fi
+
+       # Remove some default rules that don't work well on embedded devices
+       #rm ${D}${libexecdir}/rules.d/60-persistent-input.rules
+       #rm ${D}${libexecdir}/rules.d/60-persistent-storage.rules
+       #rm ${D}${libexecdir}/rules.d/60-persistent-storage-tape.rules
+
+       install -d ${D}${sysconfdir}/udev/scripts/
+
+       install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
+       install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
+}
+
+do_install_append_h2200() {
+       install -m 0644 ${WORKDIR}/50-hostap_cs.rules         ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
+}
diff --git a/meta/packages/udev/udev_158.bb b/meta/packages/udev/udev_158.bb
new file mode 100644 (file)
index 0000000..fbdb147
--- /dev/null
@@ -0,0 +1,3 @@
+include udev-new.inc
+
+PR = "r0"