]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-demos: add glut dependency
authorTrevor Woerner <twoerner@gmail.com>
Sat, 15 Apr 2017 22:44:05 +0000 (18:44 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 19 Apr 2017 09:16:22 +0000 (10:16 +0100)
If the user wants to enable the 'glut' PACKAGECONFIG for mesa-demos, freeglut
is required to provide the dependency before the demos can be compiled.

NOTE! this is a cross-layer dependency (freeglut is currently only available
in meta-oe). However 'glut' is not a default PACKAGECONFIG (so this is
allowed).

Signed-off-by: Trevor Woerner <twoerner@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb

index e80d1e8acb07e16feee1037fe5e9c17f61563040..e43b9effbac0a3f93d9702f07aa045c6537a3cbe 100644 (file)
@@ -40,7 +40,7 @@ PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
 PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
 PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
 PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
-PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
+PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,freeglut"
 PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
 PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
 PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"