]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysstat: add sysstat 9.1.4
authorYu Ke <ke.yu@intel.com>
Thu, 26 Aug 2010 03:40:08 +0000 (11:40 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:29:50 +0000 (13:29 +0100)
sysstat is a collection of performance monitoring tools. this commit adds sysstat 9.1.4.
the recipe is ported from OE, with following changes:

- upgrade to 9.1.4
- use populate-volatile to populate /var/log/sa

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta-lsb/packages/sysstat/files/99_sysstat [new file with mode: 0644]
meta-lsb/packages/sysstat/sysstat.inc [new file with mode: 0644]
meta-lsb/packages/sysstat/sysstat_9.1.4.bb [new file with mode: 0644]

diff --git a/meta-lsb/packages/sysstat/files/99_sysstat b/meta-lsb/packages/sysstat/files/99_sysstat
new file mode 100644 (file)
index 0000000..0b0ec30
--- /dev/null
@@ -0,0 +1 @@
+d root root 0755 /var/log/sa none
diff --git a/meta-lsb/packages/sysstat/sysstat.inc b/meta-lsb/packages/sysstat/sysstat.inc
new file mode 100644 (file)
index 0000000..564bc7d
--- /dev/null
@@ -0,0 +1,33 @@
+DESCRIPTION = "The sysstat utilities are a collection of performance monitoring tools for Linux."
+HOMEPAGE = "http://sebastien.godard.pagesperso-orange.fr/"
+LICENSE = "GPLv2+"
+SECTION = "console/utils"
+
+DEPENDS = "virtual/libintl"
+
+SRC_URI = "http://pagesperso-orange.fr/sebastien.godard/sysstat-${PV}.tar.gz \
+                  file://99_sysstat"
+
+inherit autotools
+
+do_install() {
+       autotools_do_install
+
+       # don't install /var/log/sa when populating rootfs. Do it through volatile
+
+       rm -rf ${D}/var
+       install -d ${D}/etc/default/volatiles
+       install -m 0644 ${WORKDIR}/99_sysstat ${D}/etc/default/volatiles
+}
+
+pkg_postinst_${PN} () {
+        /etc/init.d/populate-volatile.sh update
+}
+
+
+FILES_${PN} += "${libdir}/sa"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+LDFLAGS_append_linux-uclibc = " -lintl"
+LDFLAGS_append_linux-uclibceabi = " -lintl"
+LDFLAGS_append_linux-uclibcspe = " -lintl"
diff --git a/meta-lsb/packages/sysstat/sysstat_9.1.4.bb b/meta-lsb/packages/sysstat/sysstat_9.1.4.bb
new file mode 100644 (file)
index 0000000..d7b7e66
--- /dev/null
@@ -0,0 +1,7 @@
+require sysstat.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
+
+PR = "r0"
+
+