]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: Use echo to change the psplash progress fifo instead of forking
authorRichard Purdie <richard@openedhand.com>
Tue, 12 Aug 2008 15:42:16 +0000 (15:42 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 12 Aug 2008 15:42:16 +0000 (15:42 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5060 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/sysvinit/sysvinit/rc
meta/packages/sysvinit/sysvinit_2.86.bb

index 30b69ad51643da30b165f28c8dca4dc7a609ad72..dce31a5c98799bfb0e9d64ab3dfedd4e97bfc8a3 100755 (executable)
@@ -26,8 +26,11 @@ startup_progress() {
         progress=$progress_size
     fi
     #echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size"
-    if type psplash-write >/dev/null 2>&1; then
-        TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true
+    #if type psplash-write >/dev/null 2>&1; then
+    #    TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true
+    #fi
+    if [ -e /mnt/.psplash/psplash_fifo ]; then
+        echo "PROGRESS $progress" > /mnt/.psplash/psplash_fifo
     fi
 }
 
index e30970cb709cd5ca8eb69a8eaf34afd7d0a01af7..407ffd3369c1361117185c645d3bb4d9a9b263e0 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
 SECTION = "base"
 LICENSE = "GPL"
 HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r30"
+PR = "r31"
 
 # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
 # Set PACKAGE_ARCH appropriately.