]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemuppc: add libqtopengl4 for ppc
authorMei Lei <lei.mei@intel.com>
Mon, 4 Apr 2011 09:17:25 +0000 (17:17 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Apr 2011 16:25:58 +0000 (17:25 +0100)
Modify some configs for ppc to enable the libqtopengl4 support.
This fixes [YOCTO #848]

Signed-off-by: Mei Lei <lei.mei@intel.com>
meta/conf/machine/qemuppc.conf
meta/recipes-extended/tasks/task-poky-lsb.bb
meta/recipes-qt/qt4/qt4-x11-free.inc

index 83d08411599940aa4a21ae1fdb3578717c0c5e42..bfbcc7f1aab8e01e4d9d741909bea63c5e694473 100644 (file)
@@ -4,6 +4,8 @@
 
 TARGET_ARCH = "powerpc"
 
+PREFERRED_PROVIDER_virtual/libgl  = "mesa-xlib"
+
 require conf/machine/include/qemu.inc
 require conf/machine/include/tune-ppc603e.inc
 
index 7b3c41a85c91f0e0495b8fecbc742ab43fdbf15c..6fea613cc023ed12a8ff9571ee2689ee7c9331da 100644 (file)
@@ -172,6 +172,9 @@ RDEPENDS_task-poky-lsb-graphic-add_qemux86 = "\
 RDEPENDS_task-poky-lsb-graphic-add_atom-pc = "\
     libqtopengl4 \
 "
+RDEPENDS_task-poky-lsb-graphic-add_qemuppc = "\
+    libqtopengl4 \
+"
 
 #    mesa-dri 
 
index 057a129ecf7b44cf0427d3fcd378dc9ddf28562d..306adb9d2e8c40983fb236d444e8f8b4b6c4fbf4 100644 (file)
@@ -12,6 +12,7 @@ QT_GLFLAGS ?= "-no-opengl"
 QT_GLFLAGS_qemux86 = "-opengl"
 QT_GLFLAGS_emenlow = "-opengl"
 QT_GLFLAGS_atom-pc = "-opengl"
+QT_GLFLAGS_qemuppc = "-opengl"
 QT_CONFIG_FLAGS += "-no-xinerama -no-xkb ${QT_GLFLAGS}"
 QT_BASE_NAME ?= "qt4"
 QT_BASE_LIB  ?= "libqt"