]> code.ossystems Code Review - openembedded-core.git/commitdiff
git: remove unpackaged perl-native files
authorWenzong Fan <wenzong.fan@windriver.com>
Fri, 25 Jan 2013 08:06:56 +0000 (16:06 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 Jan 2013 12:35:49 +0000 (12:35 +0000)
${libdir} is not applicable for the install path of perl-native files,
files are always installed to /usr/lib no matter the target is 32/64
bits. After installing, remove unpackaged and unneeded perl-native
files to prevent warnings.

Fix warning:
    WARNING: For recipe git, the following files/directories were \
        installed but not shipped in any package:
    ...
    WARNING:   /usr/lib/perl-native/perl/5.14.2/Git.pm
    WARNING:   /usr/lib/perl-native/perl/5.14.2/perllocal.pod
    WARNING:   /usr/lib/perl-native/perl/5.14.2/Error.pm
    WARNING:   /usr/lib/perl-native/perl/5.14.2/auto

[YOCTO#3780]

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/git/git.inc
meta/recipes-devtools/git/git_1.8.0.2.bb

index 82df6e3d7a91b3c4d9b905a0a5a74933a866a52f..9829eec6ec6819b2d806b6e63a956939ce7ad0e6 100644 (file)
@@ -28,7 +28,11 @@ do_install () {
        oe_runmake install DESTDIR="${D}" bindir=${bindir} \
                template_dir=${datadir}/git-core/templates \
                GIT_PYTHON_DIR=${D}${datadir}/git-core/python
-       rm -rf ${D}${libdir}/perl-native
+
+       # ${libdir} is not applicable here, perl-native files are always
+       # installed to /usr/lib on both 32/64 bits targets.
+       rm -rf ${D}/usr/lib/perl-native
+       rmdir ${D}/usr/lib || true
 }
 
 do_install_append_class-native() {
index 5e5a23eb7562fb4ce6e02f17f8dd890b953bf4bd..ae6fc4153fe4d26cdd011f36f9eab5fad78924a5 100644 (file)
@@ -1,6 +1,6 @@
 require git.inc
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://git-core.googlecode.com/files/git-${PV}.tar.gz"
 SRC_URI[md5sum] = "1aca109d4a719fe5bc43d25927fbc7d9"