]> code.ossystems Code Review - openembedded-core.git/commitdiff
sed: use BPN for alternatives
authorMark Hatle <mark.hatle@windriver.com>
Tue, 22 May 2012 17:38:19 +0000 (12:38 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 May 2012 09:43:42 +0000 (10:43 +0100)
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-extended/sed/sed_4.1.2.bb
meta/recipes-extended/sed/sed_4.2.1.bb

index 8baa180f720cdb7433380fd6974f1b5392b2ee21..ca22736b7f7879a6a58c70b38e88fc319c8c204f 100644 (file)
@@ -17,12 +17,12 @@ inherit autotools update-alternatives gettext
 do_install () {
        autotools_do_install
        install -d ${D}${base_bindir}
-       mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+       mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${BPN}
        rmdir ${D}${bindir}/
 }
 
 ALTERNATIVE_NAME = "sed"
-ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_PATH = "sed.${BPN}"
 ALTERNATIVE_LINK = "${base_bindir}/sed"
 ALTERNATIVE_PRIORITY = "100"
 
index 0fceecd6bec6cb8031e661736c505ea5a837a953..b39eca0bc0a2ac847d5aba7becbef292679e13e5 100644 (file)
@@ -18,12 +18,12 @@ EXTRA_OECONF = "--disable-acl"
 do_install () {
        autotools_do_install
        install -d ${D}${base_bindir}
-       mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+       mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${BPN}
        rmdir ${D}${bindir}/
 }
 
 ALTERNATIVE_NAME = "sed"
-ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_PATH = "sed.${BPN}"
 ALTERNATIVE_LINK = "${base_bindir}/sed"
 ALTERNATIVE_PRIORITY = "100"