]> code.ossystems Code Review - openembedded-core.git/commitdiff
pkgconfig: Fix problems with the sysroot implementation merged upstream, switch pkgco...
authorRichard Purdie <richard@openedhand.com>
Wed, 26 Mar 2008 22:37:55 +0000 (22:37 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 26 Mar 2008 22:37:55 +0000 (22:37 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4126 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pkgconfig/pkgconfig-0.23/sysrootfix.patch [new file with mode: 0644]
meta/packages/pkgconfig/pkgconfig.inc
meta/packages/pkgconfig/pkgconfig_0.23.bb

diff --git a/meta/packages/pkgconfig/pkgconfig-0.23/sysrootfix.patch b/meta/packages/pkgconfig/pkgconfig-0.23/sysrootfix.patch
new file mode 100644 (file)
index 0000000..c5ee82e
--- /dev/null
@@ -0,0 +1,31 @@
+Index: pkg-config-0.23/pkg.c
+===================================================================
+--- pkg-config-0.23.orig/pkg.c 2008-03-26 22:18:39.000000000 +0000
++++ pkg-config-0.23/pkg.c      2008-03-26 22:31:11.000000000 +0000
+@@ -472,19 +472,15 @@
+   while (tmp != NULL)
+     {
+       char *tmpstr = (char*) tmp->data;
+-      if (pcsysrootdir != NULL)
++      if (pcsysrootdir != NULL && tmpstr[0] == '-' &&
++            (tmpstr[1] == 'I' || tmpstr[1] == 'L'))
+       {
+-        if (tmpstr[0] == '-' &&
+-            (tmpstr[1] == 'I' ||
+-             tmpstr[1] == 'L'))
+-          {
+-            g_string_append_c (str, '-');
+-            g_string_append_c (str, tmpstr[1]);
+-            g_string_append (str, pcsysrootdir);
+-            g_string_append (str, tmpstr+2);
+-          }
++        g_string_append_c (str, '-');
++        g_string_append_c (str, tmpstr[1]);
++        g_string_append (str, pcsysrootdir);
++        g_string_append (str, tmpstr+2);
+       }
+-      else 
++      else
+       {
+         g_string_append (str, tmpstr);
+       }
index d4607f17336f49c2cdc91047a39ae5978d06d08b..6fec0c3645d2e6088c6acbbe3315b6076a190cc8 100644 (file)
@@ -5,9 +5,10 @@ It replaces the ubiquitous *-config scripts you may have \
 seen with a single tool."
 HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
 LICENSE = "GPL"
-PR = "r3"
+PR = "r6"
 
 SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
+           file://sysrootfix.patch;patch=1 \
            file://glibconfig-sysdefs.h"
 
 S = "${WORKDIR}/pkg-config-${PV}/"
index 599e1c815ec40a48db23c21fbe2d51d4f0ef3a9f..39fdc30f2cf92dd98994a80f74e1c8a1fb021a9b 100644 (file)
@@ -1,3 +1,6 @@
 require pkgconfig.inc
 
 SRC_URI += "file://autofoo.patch;patch=1"
+
+DEPENDS += "glib-2.0"
+EXTRA_OECONF = "--with-installed-glib"