]> code.ossystems Code Review - openembedded-core.git/commitdiff
piglit: Backport linker flag patch
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Tue, 13 Sep 2016 08:46:40 +0000 (11:46 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 14 Sep 2016 21:20:05 +0000 (22:20 +0100)
Use the correct build system patch instead of adding linker flags
in recipe. Also update upstream status for the other build patch.

Fixes [YOCTO #9851].

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/piglit/piglit/0001-cmake-Link-test-utils-with-ldl.patch [new file with mode: 0644]
meta/recipes-graphics/piglit/piglit/0001-cmake-Link-utils-with-xcb-explicitly.patch
meta/recipes-graphics/piglit/piglit_git.bb

diff --git a/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-test-utils-with-ldl.patch b/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-test-utils-with-ldl.patch
new file mode 100644 (file)
index 0000000..2e1c947
--- /dev/null
@@ -0,0 +1,41 @@
+Backport patch to fix build with gold linker.
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Upstream-Status: Backport
+
+
+
+From 93a7113485cf1c55fd7076116faf5b3a690706b2 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Tue, 30 Aug 2016 17:17:28 +0300
+Subject: [PATCH] cmake: Link test utils with "-ldl"
+
+Without this linking CXX executables (e.g. fbo-blit-stretch) fails
+with gold linker:
+
+| libpiglitutil_gl.so.0: error: undefined reference to 'dlsym'
+| libpiglitutil_gl.so.0: error: undefined reference to 'dlerror'
+| libpiglitutil_gl.so.0: error: undefined reference to 'dlopen'
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
+---
+ tests/util/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/util/CMakeLists.txt b/tests/util/CMakeLists.txt
+index e1f8073..3d5bef5 100644
+--- a/tests/util/CMakeLists.txt
++++ b/tests/util/CMakeLists.txt
+@@ -11,6 +11,8 @@ set_source_files_properties(
+       PROPERTIES GENERATED 1
+       )
++link_libraries(${CMAKE_DL_LIBS})
++
+ if(HAVE_LIBCACA)
+     link_libraries(caca)
+ endif()
+-- 
+2.9.3
+
index d591da5d6b2f9ba7bd2751c3fd6c5cb97eba517c..845804dd66d85bf895989728f564dbd111bb939e 100644 (file)
@@ -13,7 +13,7 @@ This may have appeared now because xcb-dri2 used to overlink publicly
 but now does not.
 
 Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
-Upstream-Status: Pending
+Upstream-Status: Accepted
 ---
  CMakeLists.txt            | 1 +
  tests/util/CMakeLists.txt | 2 ++
index b2ca55322f41054d01d797af2db80699322668f3..82adcdeca17e437a5947c0aeec5654bef7a36b5a 100644 (file)
@@ -6,6 +6,7 @@ SRC_URI = "git://anongit.freedesktop.org/piglit \
            file://0001-cmake-install-bash-completions-in-the-right-place.patch \
            file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
            file://0001-cmake-Link-utils-with-xcb-explicitly.patch \
+           file://0001-cmake-Link-test-utils-with-ldl.patch \
            "
 
 # From 2016-07-07
@@ -30,8 +31,6 @@ do_compile[dirs] =+ "${B}/temp/"
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
 
-LDFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '-ldl', '', d)}"
-
 do_configure_prepend() {
    if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
         sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h