]> code.ossystems Code Review - openembedded-core.git/commitdiff
oprofile: Include config.h before bfd.h
authorKhem Raj <raj.khem@gmail.com>
Wed, 8 Aug 2012 14:57:46 +0000 (07:57 -0700)
committerSaul Wold <sgw@linux.intel.com>
Thu, 6 Dec 2012 07:42:33 +0000 (23:42 -0800)
oprofile uses bfd.h from binutils which now in 2.23+ expects config.h
so lets include it

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/oprofile/oprofile.inc
meta/recipes-kernel/oprofile/oprofile/fix-bfd-include.patch [new file with mode: 0644]

index ac8ce10440d6da70e284802d4751421e06128bb7..b3ce852bba92f4d672adb0901216bb5a05425835 100644 (file)
@@ -19,17 +19,17 @@ FILES_${PN} = "${bindir} ${libdir}/${BPN}/lib*${SOLIBS} ${datadir}/${BPN}"
 FILES_${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/lib*.la"
 FILES_${PN}-staticdev += "${libdir}/${BPN}/lib*.a"
 
-INC_PR = "r1"
+INC_PR = "r2"
 
 SRC_URI = "file://opstart.patch \
            file://oprofile-no-query-modules.patch \
            file://oprofile-root.patch \
+           file://fix-bfd-include.patch \
            file://acinclude.m4"
 
 inherit autotools
 
 EXTRA_OECONF = "--with-kernel-support --without-x"
-
 do_configure () {
        cp ${WORKDIR}/acinclude.m4 ${S}/
        autotools_do_configure
diff --git a/meta/recipes-kernel/oprofile/oprofile/fix-bfd-include.patch b/meta/recipes-kernel/oprofile/oprofile/fix-bfd-include.patch
new file mode 100644 (file)
index 0000000..944320f
--- /dev/null
@@ -0,0 +1,66 @@
+bfd.h now wants to include autotools generated config.h for reasoning read
+http://sourceware.org/bugzilla/show_bug.cgi?id=14243
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: oprofile-0.9.7/libutil++/bfd_support.h
+===================================================================
+--- oprofile-0.9.7.orig/libutil++/bfd_support.h        2011-07-04 19:25:04.000000000 -0700
++++ oprofile-0.9.7/libutil++/bfd_support.h     2012-12-02 10:51:23.518784249 -0800
+@@ -11,6 +11,7 @@
+ #ifndef BFD_SUPPORT_H
+ #define BFD_SUPPORT_H
++#include "config.h"
+ #include "utility.h"
+ #include "op_types.h"
+ #include "locate_images.h"
+Index: oprofile-0.9.7/libopagent/opagent.c
+===================================================================
+--- oprofile-0.9.7.orig/libopagent/opagent.c   2011-07-04 19:25:04.000000000 -0700
++++ oprofile-0.9.7/libopagent/opagent.c        2012-12-02 10:58:10.954804150 -0800
+@@ -50,6 +50,7 @@
+  *   See libopagent/Makefile.am for more information.
+  *******************************************************************/
++#include "config.h"
+ #include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
+Index: oprofile-0.9.7/libpp/symbol.h
+===================================================================
+--- oprofile-0.9.7.orig/libpp/symbol.h 2011-07-04 19:25:04.000000000 -0700
++++ oprofile-0.9.7/libpp/symbol.h      2012-12-02 10:59:59.434809273 -0800
+@@ -18,6 +18,7 @@
+ #include "format_flags.h"
+ #include "op_types.h"
++#include "config.h"
+ #include <bfd.h>
+ #include <stdint.h>
+Index: oprofile-0.9.7/opjitconv/debug_line.c
+===================================================================
+--- oprofile-0.9.7.orig/opjitconv/debug_line.c 2011-07-04 19:25:04.000000000 -0700
++++ oprofile-0.9.7/opjitconv/debug_line.c      2012-12-02 11:02:26.046816339 -0800
+@@ -8,6 +8,7 @@
+  * @author Philippe Elie
+  */
++#include "config.h"
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
+Index: oprofile-0.9.7/opjitconv/opjitconv.h
+===================================================================
+--- oprofile-0.9.7.orig/opjitconv/opjitconv.h  2011-07-04 19:25:04.000000000 -0700
++++ oprofile-0.9.7/opjitconv/opjitconv.h       2012-12-02 11:01:25.558813373 -0800
+@@ -26,6 +26,7 @@
+ #define OP_JIT_CONV_ALREADY_DONE 5
+ #define OP_JIT_CONV_TMPDIR_NOT_REMOVED 6
++#include "config.h"
+ #include <bfd.h>
+ #include <stddef.h>
+ #include <sys/stat.h>