]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils: disable werror on native build
authorDan McGregor <dan.mcgregor@usask.ca>
Wed, 11 May 2016 17:35:16 +0000 (10:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 13 May 2016 12:40:51 +0000 (13:40 +0100)
It's disabled on cross builds, and it's needed for gcc 6

Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/binutils/binutils_2.26.bb

index b70ffbf28af05adf0761605997e04c9f5d4589cd..e976bad3ed3b3ef6aa870f0514e311853002e472 100644 (file)
@@ -13,7 +13,8 @@ EXTRA_OECONF += "--with-sysroot=/ \
 EXTRA_OECONF_class-native = "--enable-targets=all \
                              --enable-64-bit-bfd \
                              --enable-install-libiberty \
-                             --enable-install-libbfd"
+                             --enable-install-libbfd \
+                             --disable-werror"
 
 do_install_class-native () {
        autotools_do_install