]> code.ossystems Code Review - openembedded-core.git/commitdiff
opensp: Fix sstate relocation issue
authorSaul Wold <sgw@linux.intel.com>
Sun, 4 Sep 2011 03:52:12 +0000 (20:52 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Sep 2011 16:53:02 +0000 (17:53 +0100)
[YOCTO #1440]

This fixes a problem where the native nsgmls has a path hard coded into
it, therefor add a wrapper to set the environment with the correct
paths for catalog files.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/opensp/opensp_1.5.bb

index a402d11c726de3b28865297587548b8a7469eb43..0269c87be450fc9ffe5b5ce32ac8c1acadd734ab 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
 
-PR = "r1"
+PR = "r2"
 
 # At -Os it encounters calls to some inline functions which are then
 # not found in any other objects with gcc 4.5
@@ -42,6 +42,13 @@ do_install_append() {
        ln -sf osx sgml2xml
 }
 
+do_install_append_virtclass-native() {
+       for util in nsgmls sgmlnorm spam spcat spent sx; do
+               create_wrapper ${D}/${bindir}/$util \
+                   SGML_CATALOG_FILES=${sysconfdir}/sgml/catalog 
+       done
+}
+
 FILES_${PN} += "${datadir}/OpenSP/"
 
 BBCLASSEXTEND = "native"