]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm_5.1.10: Disable dependency loop message
authorMark Hatle <mark.hatle@windriver.com>
Wed, 29 Sep 2010 17:40:36 +0000 (12:40 -0500)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 30 Sep 2010 17:05:43 +0000 (10:05 -0700)
[BUGID #332]

Disable the dependency loop message that looked like an error had
occured.  This is really a debug message.

Also remove the "remove: " debug message about which side of the
dep loop it is removing to resolve the circular dependency.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/rpm/rpm/rpm-no-loop.patch [new file with mode: 0644]
meta/recipes-devtools/rpm/rpm_5.1.10.bb

diff --git a/meta/recipes-devtools/rpm/rpm/rpm-no-loop.patch b/meta/recipes-devtools/rpm/rpm/rpm-no-loop.patch
new file mode 100644 (file)
index 0000000..1f0dbcb
--- /dev/null
@@ -0,0 +1,38 @@
+The LOOP: ... messages appear to be errors, but in reality they are
+simply debug messages that indicate there is one or more dependency
+loop within the system.
+
+Due to Poky packages owning all of the directories they use, a large
+number of depedency loops may be present.  So disabling this message
+seems to make the most sense.
+
+Signed-off-by: mark.hatle@windriver.com
+
+diff -ur rpm-5.1.10.orig/lib/depends.c rpm-5.1.10/lib/depends.c
+--- rpm-5.1.10.orig/lib/depends.c      2010-09-29 12:23:48.307048065 -0500
++++ rpm-5.1.10/lib/depends.c   2010-09-29 12:33:23.306022259 -0500
+@@ -2044,9 +2044,11 @@
+        * Attempt to unravel a dependency loop by eliminating Requires's.
+        */
+       if (zap) {
++#if 0
+           rpmlog(msglvl,
+                       _("removing %s \"%s\" from tsort relations.\n"),
+                       (rpmteNEVRA(p) ?  rpmteNEVRA(p) : "???"), dp);
++#endif
+           rpmteTSI(p)->tsi_count--;
+           if (tsi_prev) tsi_prev->tsi_next = tsi->tsi_next;
+           tsi->tsi_next = NULL;
+@@ -2676,10 +2678,12 @@
+               /* Unchain predecessor loop. */
+               rpmteTSI(p)->tsi_chain = NULL;
++#if 0
+               if (!printed) {
+                   rpmlog(msglvl, _("LOOP:\n"));
+                   printed = 1;
+               }
++#endif
+               /* Find (and destroy if co-requisite) "q <- p" relation. */
+               dp = zapRelation(q, p, 1, &nzaps, msglvl);
index e5ccf8e99da396bf67a50b9442e4431f37adba97..cbae3f3b317529f9473c97f22ef033e715492482 100644 (file)
@@ -12,6 +12,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.1/SNAPSHOT/${BPN}-${PV}.tar.gz \
           file://rpm-autoconf.patch \
           file://remove-compiled-tests.patch;apply=no \
           file://perfile_rpmdeps.sh \
+          file://rpm-no-loop.patch \
          "
 inherit autotools gettext