]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: opkg-build exit when fail to list files.
authorAníbal Limón <anibal.limon@linux.intel.com>
Fri, 1 Apr 2016 16:27:10 +0000 (10:27 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 Apr 2016 14:51:09 +0000 (15:51 +0100)
We have an issue when ls segfaults in some cases [1] so it's
better to detect the failure at this level instead of continue
the build process.

[YOCTO #8926]

[1] https://bugzilla.yoctoproject.org/show_bug.cgi?id=8926#c0

Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/opkg-utils/opkg-utils/opkg-build-Exit-when-fail-to-list-files.patch [new file with mode: 0644]
meta/recipes-devtools/opkg-utils/opkg-utils_git.bb

diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/opkg-build-Exit-when-fail-to-list-files.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/opkg-build-Exit-when-fail-to-list-files.patch
new file mode 100644 (file)
index 0000000..6c66902
--- /dev/null
@@ -0,0 +1,45 @@
+We have an issue when ls segfaults in some cases [1] so it's
+better to detect the failure at this level instead of continue
+the build process.
+
+[YOCTO #8926]
+
+Upstream-Status: Submitted [2]
+
+[1] https://bugzilla.yoctoproject.org/show_bug.cgi?id=8926#c0
+[2] https://groups.google.com/forum/#!topic/opkg-devel/cmX02bgHZms
+
+Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
+---
+ opkg-build | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/opkg-build b/opkg-build
+index 98008b6..a9ccad2 100755
+--- a/opkg-build
++++ b/opkg-build
+@@ -53,6 +53,10 @@ pkg_appears_sane() {
+               echo "*** Warning: The following files have names ending in '~'.
+ You probably want to remove them: " >&2
+               ls -ld $tilde_files
++              if [ $? -ne 0 ]; then
++                      echo "*** Error: Fail to list files have names ending in '~'."
++                      exit 1
++              fi
+               echo >&2
+           else
+               echo "*** Removing the following files: $tilde_files"
+@@ -66,6 +70,10 @@ You probably want to remove them: " >&2
+               echo "*** Warning: The following files have a UID greater than 99.
+ You probably want to chown these to a system user: " >&2
+               ls -ld $large_uid_files
++              if [ $? -ne 0 ]; then
++                      echo "*** Error: Fail to list files have a UID greater than 99."
++                      exit 1
++              fi
+               echo >&2
+       fi
+           
+-- 
+2.1.4
+
index 1bc561c08a3f2ab081727964513d2b17c1188059..22f45a1d8d8782d23a289cf25d6f598299f655d4 100644 (file)
@@ -10,8 +10,8 @@ PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtu
 SRCREV = "53274f087565fd45d8452c5367997ba6a682a37a"
 PV = "0.1.8+git${SRCPV}"
 
-SRC_URI = "git://git.yoctoproject.org/opkg-utils"
-
+SRC_URI = "git://git.yoctoproject.org/opkg-utils \
+           file://opkg-build-Exit-when-fail-to-list-files.patch"
 SRC_URI_append_class-native = " file://tar_ignore_error.patch"
 
 S = "${WORKDIR}/git"