]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add leafpad 0.8.9 and fix leafpad depends. Also add some missing patches
authorRichard Purdie <richard@openedhand.com>
Tue, 9 May 2006 22:11:25 +0000 (22:11 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 9 May 2006 22:11:25 +0000 (22:11 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@392 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/leafpad/leafpad_0.8.4.bb
openembedded/packages/leafpad/leafpad_0.8.9.bb [new file with mode: 0644]
openembedded/packages/libxml/files/no-testapi.patch [new file with mode: 0644]
openembedded/packages/perl/files/Configure-multilib.patch [new file with mode: 0644]

index c26f149777ac9b4b8c540eaf44fb0d0518206818..1b1d23fa2a9493fb9f9678fc3edee91126ca082d 100644 (file)
@@ -1,5 +1,5 @@
 LICENSE = "GPLv2"
-DEPENDS = "gtk+"
+DEPENDS = "gtk+ intltool-native"
 SRC_URI = "http://savannah.nongnu.org/download/${PN}/${PN}-${PV}.tar.gz \
           file://leafpad.desktop \
           file://leafpad.png"
diff --git a/openembedded/packages/leafpad/leafpad_0.8.9.bb b/openembedded/packages/leafpad/leafpad_0.8.9.bb
new file mode 100644 (file)
index 0000000..1b1d23f
--- /dev/null
@@ -0,0 +1,21 @@
+LICENSE = "GPLv2"
+DEPENDS = "gtk+ intltool-native"
+SRC_URI = "http://savannah.nongnu.org/download/${PN}/${PN}-${PV}.tar.gz \
+          file://leafpad.desktop \
+          file://leafpad.png"
+PR = "r1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --enable-chooser --disable-gtktest --disable-print"
+
+do_install_append () {
+        install -d ${D}/${datadir}
+        install -d ${D}/${datadir}/applications
+        install -d ${D}/${datadir}/pixmaps/
+
+        install -m 0644 ${WORKDIR}/leafpad.png ${D}/${datadir}/pixmaps
+        install -m 0644 ${WORKDIR}/leafpad.desktop ${D}/${datadir}/applications
+}
+
+FILES_${PN} += "${datadir}/applications/leafpad.desktop ${datadir}/pixmaps/leafpad.png"
diff --git a/openembedded/packages/libxml/files/no-testapi.patch b/openembedded/packages/libxml/files/no-testapi.patch
new file mode 100644 (file)
index 0000000..15a4dea
--- /dev/null
@@ -0,0 +1,51 @@
+--- /tmp/Makefile.am   2005-11-13 14:33:15.844432536 +0100
++++ libxml2-2.6.22/Makefile.am 2005-11-13 14:33:25.796919528 +0100
+@@ -8,7 +8,7 @@
+ noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
+                 testThreads testC14N testAutomata testRegexp \
+-                testReader testapi testModule runtest runsuite
++                testReader testModule runtest runsuite
+ bin_PROGRAMS = xmllint xmlcatalog
+@@ -135,20 +135,9 @@
+ testdso_la_LDFLAGS = -module -rpath $(libdir)
+ # that one forces the rebuild when "make rebuild" is run on doc/
+-rebuild_testapi:
+-      -@(if [ "$(PYTHON)" != "" ] ; then \
+-          $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
+ # that one is just to make sure it is rebuilt if missing
+ # but adding the dependances generate mess
+-testapi.c:
+-      -@(if [ "$(PYTHON)" != "" ] ; then \
+-          $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
+-
+-testapi_SOURCES=testapi.c
+-testapi_LDFLAGS = 
+-testapi_DEPENDENCIES = $(DEPS)
+-testapi_LDADD= $(LDADDS)
+ #testOOM_SOURCES=testOOM.c testOOMlib.h testOOMlib.c
+ #testOOM_LDFLAGS = 
+@@ -169,9 +158,6 @@
+       @echo '## Go get a cup of coffee it is gonna take a while ...'
+       $(MAKE) CHECKER='valgrind' tests
+-APItests: testapi$(EXEEXT)
+-      @echo "## Running the API regression tests this may take a little while"
+-      -@($(CHECKER) $(top_builddir)/testapi -q)
+ HTMLtests : testHTML$(EXEEXT)
+       @(echo > .memdump)
+@@ -1116,7 +1102,7 @@
+ dist-test: distdir
+       (mkdir -p $(distdir))
+       (cd $(srcdir) ; tar -cf - --exclude CVS xstc/Tests) | (cd $(distdir); tar xf -)
+-      tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests  $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/testapi.c $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
++      tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests  $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
+       @(rm -rf $(distdir)/xstc/Test)
+ cleantar:
diff --git a/openembedded/packages/perl/files/Configure-multilib.patch b/openembedded/packages/perl/files/Configure-multilib.patch
new file mode 100644 (file)
index 0000000..d3948a9
--- /dev/null
@@ -0,0 +1,11 @@
+--- perl-5.8.7/Configure.orig  2006-01-30 10:50:04.000000000 +0000
++++ perl-5.8.7/Configure       2006-01-30 10:51:18.000000000 +0000
+@@ -1240,7 +1240,7 @@
+ loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
+ : general looking path for locating libraries
+-glibpth="/lib /usr/lib $xlibpth"
++glibpth="/lib /usr/lib /lib64 /usr/lib64 $xlibpth"
+ glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
+ test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
+ test -f /shlib/libc.so     && glibpth="/shlib $glibpth"