]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: use /bin/bash as default shell when bash is included
authorKevin Tian <kevin.tian@intel.com>
Wed, 26 Jan 2011 11:37:10 +0000 (19:37 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 28 Jan 2011 16:49:12 +0000 (16:49 +0000)
though bash is included in LSB profile, it doesn't use update-alternative
to take effect and thus it's still busybox behaving as /bin/sh.

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/recipes-extended/bash/bash.inc
meta/recipes-extended/bash/bash_3.2.48.bb
meta/recipes-extended/bash/bash_4.1.bb

index aa8cac82223b7d1f1802d2df60dc258779d644f7..a87b87ff4b9c360f477f9c866b0b67dcab9574c6 100644 (file)
@@ -17,6 +17,11 @@ sbindir = "/sbin"
 EXTRA_OECONF = "--enable-job-control"
 export CC_FOR_BUILD = "${BUILD_CC}"
 
+ALTERNATIVE_NAME = "sh"
+ALTERNATIVE_PATH = "${base_bindir}/bash"
+ALTERNATIVE_LINK = "${base_bindir}/sh"
+ALTERNATIVE_PRIORITY = "100"
+
 do_configure () {
        gnu-configize
        oe_runconf
index ee563d626a5ab5efa1148ff6f34b47fb154898e4..e5a3e3643d17f150f4eb17851f1a2089cbea6bb0 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
 DEPENDS = "ncurses"
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
            http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0 \
index 6a558ed2cde0c5ee2abcf72b12cec4679e7ac36e..cea40420cb7cc027db27d719afca8b29844e6155 100644 (file)
@@ -1,6 +1,6 @@
 require bash.inc
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${GNU_MIRROR}/bash/${BPN}-${PV}.tar.gz;name=tarball \
            http://ftp.gnu.org/gnu/bash/bash-4.1-patches/bash41-001;apply=yes;striplevel=0;name=patch001 \