]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: package bzip2 support into separate package
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 7 Oct 2008 09:31:38 +0000 (09:31 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 7 Oct 2008 09:31:38 +0000 (09:31 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5428 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/python/python-2.5-manifest.inc
meta/packages/python/python_2.5.2.bb

index c098494d17ec231833c4de142f49262a31152331..3e7dd178e8e48542ebff8ec176ab9888f61d2d9a 100644 (file)
@@ -8,9 +8,9 @@
 ########################################################################################################################
  
 
-PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
+PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio python-bzip2 python-elementtree"
 
-PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
+PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio python-bzip2 python-elementtree"
 
 DESCRIPTION_python-profile="Python Basic Profiling Support"
 PR_python-profile="ml0"
@@ -302,5 +302,7 @@ PR_python-audio="ml0"
 RDEPENDS_python-audio="python-core"
 FILES_python-audio="${libdir}/python2.5/wave.* ${libdir}/python2.5/chunk.* ${libdir}/python2.5/sndhdr.* ${libdir}/python2.5/lib-dynload/ossaudiodev.so ${libdir}/python2.5/lib-dynload/audioop.so "
 
-
+DESCRIPTION_python-bzip2="Python bzip2 Handling"
+RDEPENDS_python-bzip2="python-core"
+FILES_python-bzip2="${libdir}/python2.5/lib-dynload/bz2.so"
 
index 1ac48f3686be9283c6cdb3275895f218d6554853..d779865801d6be1c3cf72afdfefbda7f3f32d62b 100644 (file)
@@ -3,9 +3,9 @@ HOMEPAGE = "http://www.python.org"
 LICENSE = "PSF"
 SECTION = "devel/python"
 PRIORITY = "optional"
-DEPENDS = "python-native readline zlib gdbm openssl sqlite3"
+DEPENDS = "python-native readline zlib gdbm openssl sqlite3 bzip2"
 DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml1"
+PR = "ml2"
 
 PYTHON_MAJMIN = "2.5"