]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml-simple-perl: fix build failure with perl 5.12.2
authorNitin A Kamble <nitin.a.kamble@intel.com>
Wed, 5 Jan 2011 18:14:18 +0000 (10:14 -0800)
committerSaul Wold <sgw@linux.intel.com>
Wed, 12 Jan 2011 08:55:48 +0000 (00:55 -0800)
for hostperl needing to load .so files (for module scalar::util) the host/native
perl library path is placed 1st in the @INC with the -I parameter to perl.
  Otherwise hostperl gives error can not load module scalar::util.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb

index 136e117c855e6a659269ce60a967eb60341cd483..ca57776dacbca89155ec4ab8eb2aa58a077007f3 100644 (file)
@@ -2,7 +2,7 @@ SECTION = "libs"
 LICENSE = "Artistic"
 LIC_FILES_CHKSUM = "file://README;beginline=70;md5=94aa5d46682b411a53a5494cfb22640e"
 DEPENDS += "libxml-parser-perl"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
 
@@ -11,4 +11,6 @@ SRC_URI[sha256sum] = "a54967c188cda3e20f496c83be4de3f1740eeaa83c0380712ecd969ad8
 
 S = "${WORKDIR}/XML-Simple-${PV}"
 
+EXTRA_PERLFLAGS = "-I ${STAGING_LIBDIR_NATIVE}/perl/${@get_perl_version(d)}"
+
 inherit cpan