]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemugl: remove obsolate /usr/X11R6/lib lib directory
authorYu Ke <ke.yu@intel.com>
Sat, 9 Oct 2010 01:47:52 +0000 (09:47 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 11 Oct 2010 21:16:42 +0000 (22:16 +0100)
qemugl makefile has "-L/usr/X11R6/lib" to specifiy the X lib dir.
it is actually obsolate in poky now, because poky use Xserver from
X.org (X11R7.x), and its libs are in standard /usr/lib.

Meanwhile,the -L/usr/X11R6/lib will cause warning: library search path
"/usr/X11R6/lib" is unsafe for cross-compilation. so better to remove it.

Fix [BUGID #386]

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch [new file with mode: 0644]
meta/recipes-graphics/mesa/qemugl_git.bb

diff --git a/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch b/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch
new file mode 100644 (file)
index 0000000..d14ce89
--- /dev/null
@@ -0,0 +1,19 @@
+Remove X11R6 lib directory
+
+"-L/usr/X11R6/lib" is obsolate in poky. Poky currently use Xserver from X.org (X11R7.x), which puts lib in standard /usr/lib, so no need to specify the extra -L/usr/X11R6/lib. Meanwhile, the -L/usr/X11R6/lib will cause warning: library search path "/usr/X11R6/lib" is unsafe for cross-compilation. so better to remove it.
+
+Signed-off-by: Yu Ke <ke.yu@intel.com>
+
+diff --git a/Makefile b/Makefile
+index 9e5a8ea..f3a082a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ GL_CFLAGS := -Wall -g -O2 -fno-strict-aliasing
+ all: libGL.so.1.2
+ libGL.so.1.2: client_stub.c opengl_client.c glgetv_cst.h opengl_func.h opengl_utils.h opengl_client_xfonts.c mesa_gl.h mesa_glext.h mesa_glx.h mesa_glxext.h
+-      $(CC) -fPIC $(GL_CFLAGS) opengl_client.c -shared -o libGL.so.1.2 -lX11 -lXfixes -lm -L$(D)/usr/X11R6/lib -lpthread -I.
++      $(CC) -fPIC $(GL_CFLAGS) opengl_client.c -shared -o libGL.so.1.2 -lX11 -lXfixes -lm -lpthread -I.
+ opengl_func.h: gl_func.h
index 184c7827223032406d958b2508a912fcbd5529a6..8f8929117c0c9745a8ca861e19e2067d48913706 100644 (file)
@@ -8,11 +8,12 @@ DEPENDS = "virtual/libx11 xproto glproto libxfixes"
 COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
 
 SRC_URI = "git://git.o-hand.com/qemugl.git;protocol=git \
-           file://versionfix.patch"
+           file://versionfix.patch \
+           file://remove-x11r6-lib-dir.patch"
 S = "${WORKDIR}/git"
 
 PV = "0.0+git${SRCPV}"
-PR = "r6"
+PR = "r7"
 
 DEFAULT_PREFERENCE = "-1"