]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-nose: rename ${bindir}/nosetests into ${bindir}/nosetests3
authorDenys Dmytriyenko <denys@ti.com>
Tue, 6 Feb 2018 19:48:22 +0000 (11:48 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 3 Mar 2018 08:30:37 +0000 (08:30 +0000)
This resolves a conflict when both python-nose and python3-nose are pulled
into an image and try to install ${bindir}/nosetests binary.

This matches with how other distros are solving this problem, e.g. Debian:
https://packages.debian.org/jessie/all/python3-nose/filelist

Also, other packages like python3-setuptools are already doing the same with
their binaries.

Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Kelly <mkelly@xevo.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/python/python3-nose_1.3.7.bb

index 99bba4403f47c4bcbd35043389f77671df828ef1..1e2ff74f5784392193d4efbc1c38122fc5cc900c 100644 (file)
@@ -17,6 +17,10 @@ S = "${WORKDIR}/nose-${PV}"
 
 inherit setuptools3
 
+do_install_append() {
+    mv ${D}${bindir}/nosetests ${D}${bindir}/nosetests3
+}
+
 RDEPENDS_${PN}_class-target = "\
   python3-unittest \
   "