]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnome-doc-utils: Use /usr/bin/env python in xml2po, bump PR
authorTom Rini <tom_rini@mentor.com>
Mon, 18 Jul 2011 15:14:25 +0000 (08:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Jul 2011 09:44:48 +0000 (10:44 +0100)
In oe.dev we can just sed over the binary but in newer versions of this
program we need to fix the in use copy too.  As noted in the patch header,
this isn't appropriate for upstream as it could change behavior on Windows.

Signed-off-by: Tom Rini <tom_rini@mentor.com>
meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch [new file with mode: 0644]
meta/recipes-gnome/gnome/gnome-doc-utils_0.20.6.bb

diff --git a/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch b/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch
new file mode 100644 (file)
index 0000000..a285ad2
--- /dev/null
@@ -0,0 +1,33 @@
+Upstream-Status="Inappropriate [Would break behavior on Windows]"
+
+We can't use #!/full/path/to/python -u as this can be longer than shebang
+allows for.  In order to be appropraite for upstream more work would be
+needed to make sure that the main xml2po code doesn't rely on python
+being invoked with -u (force stdin/out/err to be used raw).
+---
+ xml2po/xml2po/Makefile.am  |    1 -
+ xml2po/xml2po/xml2po.py.in |    2 +-
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+Index: gnome-doc-utils-0.20.6/xml2po/xml2po/Makefile.am
+===================================================================
+--- gnome-doc-utils-0.20.6.orig/xml2po/xml2po/Makefile.am
++++ gnome-doc-utils-0.20.6/xml2po/xml2po/Makefile.am
+@@ -7,7 +7,6 @@ CLEANFILES = xml2po
+ xml2po: xml2po.py.in
+       sed -e "s/^VERSION =.*/VERSION = \"@VERSION@\"/" \
+-          -e "s+^#!.*python.*+#!$(PYTHON)+" \
+         < $(srcdir)/xml2po.py.in > xml2po
+       chmod +x xml2po
+Index: gnome-doc-utils-0.20.6/xml2po/xml2po/xml2po.py.in
+===================================================================
+--- gnome-doc-utils-0.20.6.orig/xml2po/xml2po/xml2po.py.in
++++ gnome-doc-utils-0.20.6/xml2po/xml2po/xml2po.py.in
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python -u
++#!/usr/bin/env python
+ # -*- encoding: utf-8 -*-
+ # Copyright (c) 2004, 2005, 2006 Danilo Ĺ egan <danilo@gnome.org>.
+ # Copyright (c) 2009 Claude Paroz <claude@2xlibre.net>.
index 4554122ddc5b098b8b5b923f3533c64c4d03e2c0..1ec10760dbdc6fd5c872c805617c7f500a2777b0 100644 (file)
@@ -1,9 +1,10 @@
 require gnome-doc-utils.inc
 LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=eb723b61539feef013de476e68b5c50a \
                    file://COPYING.LGPL;md5=a6f89e2100d9b6cdffcea4f398e37343"
-PR = "r3"
+PR = "r4"
 
-SRC_URI += "file://xsltproc_nonet.patch"
+SRC_URI += "file://xsltproc_nonet.patch \
+           file://use-usr-bin-env-for-python-in-xml2po.patch"
 
 SRC_URI[archive.md5sum] = "8f6e05071599bc073007830ea0a68391"
 SRC_URI[archive.sha256sum] = "091486e370480bf45349ad09dac799211092a02938b26a0d68206172cb6cebbf"