]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-common: MesaDemos is now separate recipes, bump PE, introduce INC_PR
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 13 Oct 2011 07:49:47 +0000 (09:49 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Oct 2011 11:18:21 +0000 (12:18 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-graphics/mesa/mesa-common.inc
meta/recipes-graphics/mesa/mesa-dri_7.11.bb
meta/recipes-graphics/mesa/mesa-dri_git.bb
meta/recipes-graphics/mesa/mesa-xlib_7.11.bb

index fb9a2162f79f18fd403297e046dae9e2f140b907..ee359ba03e1f483640e72275a0f9aa428d4acbf6 100644 (file)
@@ -12,9 +12,10 @@ SECTION = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
 
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2;name=mesalib \
-           ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaDemos-${PV}.tar.bz2;name=mesademos "
+INC_PR = "r12"
+PE = "2"
 
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
 S = "${WORKDIR}/Mesa-${PV}"
 
 PROVIDES = "virtual/libgl"
index 5f15091caf86c4a1b210b88d639d0ffdb2e97918..5f14346ee141bed2b20731be3dddbf0756bdedc3 100644 (file)
@@ -7,7 +7,7 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native python-native"
 DEPENDS += "mesa-dri-glsl-native"
 
-PR = "r5"
+PR = "${INC_PR}.0"
 
 SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
            file://crossfix.patch \
index 9e32d0aeb0879a69dbc0d15090f70cee2df53224..c50ba15f53a239984a762f7913b5d9ddace8f0d8 100644 (file)
@@ -13,7 +13,7 @@ DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS}"
 
 SRCREV = "1bf94d419805538ac23a4d0b04d31ac5e4487aca"
 PV = "7.7+git${SRCPV}"
-PR = "r2"
+PR = "${INC_PR}.0"
 
 # most of our targets do not have DRI so will use mesa-xlib
 DEFAULT_PREFERENCE = "-1"
index 8b8337853a89681214869b56e136e2ef09a39f18..1e0d8211a418f68a97d47cd9f21671c3fe2d0d46 100644 (file)
@@ -12,8 +12,7 @@ LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-nativ
 
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native"
 
-PE = "1"
-PR = "r1"
+PR = "${INC_PR}.0"
 
 EXTRA_OECONF += "--with-driver=xlib --without-gallium-drivers"