]> code.ossystems Code Review - openembedded-core.git/commitdiff
oprofile: bump cvs date, fix for EABI
authorRichard Purdie <richard@openedhand.com>
Tue, 9 Jan 2007 14:52:34 +0000 (14:52 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 9 Jan 2007 14:52:34 +0000 (14:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1137 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/poky.conf
meta/packages/oprofile/oprofile/oprofile_eabi.patch [new file with mode: 0644]
meta/packages/oprofile/oprofile_cvs.bb

index 04c6fa4fca8cac56d10dab766b70882492299100..bac19f459ea8758c4b341f81148e2d423cc16a6c 100644 (file)
@@ -112,7 +112,7 @@ SRCDATE_xauth ?= "20060120"
 SRCDATE_xserver-kdrive = "20050207"
 SRCDATE_qemu ?= "20060723"
 SRCDATE_qemu-native ?= "20060723"
-SRCDATE_oprofile ?= "20061011"
+SRCDATE_oprofile ?= "20070106"
 SRCDATE_zaurusd ?= "20060729"
 SRCDATE_owl-video-widget ?= "20060925"
 SRCDATE_psplash ?= "20061220"
diff --git a/meta/packages/oprofile/oprofile/oprofile_eabi.patch b/meta/packages/oprofile/oprofile/oprofile_eabi.patch
new file mode 100644 (file)
index 0000000..b360cbe
--- /dev/null
@@ -0,0 +1,18 @@
+---
+ daemon/opd_cookie.c |    3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+Index: oprofile/daemon/opd_cookie.c
+===================================================================
+--- oprofile.orig/daemon/opd_cookie.c  2005-10-19 00:28:26.000000000 +0100
++++ oprofile/daemon/opd_cookie.c       2007-01-09 15:12:49.000000000 +0000
+@@ -68,7 +68,8 @@ static inline int lookup_dcookie(cookie_
+       return syscall(__NR_lookup_dcookie, (unsigned long)(cookie >> 32),
+                      (unsigned long)(cookie & 0xffffffff), buf, size);
+ }
+-#elif (defined(__mips__) && (_MIPS_SIM == _MIPS_SIM_ABI32)) /*_MIPSEL */
++#elif (defined(__mips__) && (_MIPS_SIM == _MIPS_SIM_ABI32)) \
++      || (defined(__arm__) && defined(__ARM_EABI__))
+ static inline int lookup_dcookie(cookie_t cookie, char * buf, size_t size)
+ {
+       return syscall(__NR_lookup_dcookie,
index 902c569e854be2ecdb506805be4ccf8fe1f9745d..d6de526b0701b14e1ae85374878878310a0fb766 100644 (file)
@@ -6,11 +6,8 @@ of profiling all running code at low overhead."
 LICENSE = "GPL"
 DEPENDS = "popt binutils"
 
-DEFAULT_PREFERENCE = "-1"
-
 SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
-          file://no_arm_mapping_syms.patch;patch=1 \
-           file://opcontrol_bashisms.patch;patch=1 \
+          file://oprofile_eabi.patch;patch=1 \
           file://acinclude.m4"
 S = "${WORKDIR}/oprofile"