]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-rp_2.6.22+2.6.23-rc4: Fix FB overlay.
authorSamuel Ortiz <sameo@openedhand.com>
Fri, 28 Sep 2007 17:43:53 +0000 (17:43 +0000)
committerSamuel Ortiz <sameo@openedhand.com>
Fri, 28 Sep 2007 17:43:53 +0000 (17:43 +0000)
With rmk's latest pxa patchset, pxa fb overlay is broken.

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2819 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/linux/linux-rp-2.6.22+2.6.23-rc4/defconfig-zylonite
meta/packages/linux/linux-rp-2.6.22+2.6.23-rc4/pxa_fb_overlay.patch [new file with mode: 0644]
meta/packages/linux/linux-rp_2.6.22+2.6.23-rc4.bb

index f10c01a3b6522148f492a7e70cb3eccaa41112ad..0321704a1f30d2626c111e84fbc6b61475ac5ba6 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Automatically generated make config: don't edit
 # Linux kernel version: 2.6.23-rc4
-# Tue Sep 25 12:39:31 2007
+# Tue Sep 25 15:57:10 2007
 #
 CONFIG_ARM=y
 CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -230,7 +230,7 @@ CONFIG_ALIGNMENT_TRAP=y
 #
 CONFIG_ZBOOT_ROM_TEXT=0x0
 CONFIG_ZBOOT_ROM_BSS=0x0
-CONFIG_CMDLINE="console=ttyS0,38400 root=/dev/mtdblock2 rootfstype=jffs2 mem=64M"
+CONFIG_CMDLINE="console=ttyS0,38400 root=/dev/mtdblock2 rootfstype=jffs2 mem=64M  dyntick=enable debug"
 # CONFIG_XIP_KERNEL is not set
 # CONFIG_KEXEC is not set
 
@@ -874,7 +874,7 @@ CONFIG_FB_MODE_HELPERS=y
 CONFIG_FB_PXA=y
 # CONFIG_FB_PXA_LCD_QVGA is not set
 CONFIG_FB_PXA_LCD_VGA=y
-# CONFIG_FB_PXA_OVERLAY is not set
+CONFIG_FB_PXA_OVERLAY=y
 # CONFIG_FB_PXA_PARAMETERS is not set
 # CONFIG_FB_MBX is not set
 # CONFIG_FB_VIRTUAL is not set
@@ -902,7 +902,7 @@ CONFIG_LOGO=y
 CONFIG_LOGO_LINUX_MONO=y
 CONFIG_LOGO_LINUX_VGA16=y
 CONFIG_LOGO_LINUX_CLUT224=y
-CONFIG_LOGO_OHAND_CLUT224=y
+# CONFIG_LOGO_OHAND_CLUT224 is not set
 # CONFIG_LOGO_OZ240_CLUT224 is not set
 # CONFIG_LOGO_OZ480_CLUT224 is not set
 # CONFIG_LOGO_OZ640_CLUT224 is not set
diff --git a/meta/packages/linux/linux-rp-2.6.22+2.6.23-rc4/pxa_fb_overlay.patch b/meta/packages/linux/linux-rp-2.6.22+2.6.23-rc4/pxa_fb_overlay.patch
new file mode 100644 (file)
index 0000000..49c59b3
--- /dev/null
@@ -0,0 +1,26 @@
+---
+ drivers/video/pxafb.h |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: linux-2.6.22/drivers/video/pxafb.h
+===================================================================
+--- linux-2.6.22.orig/drivers/video/pxafb.h    2007-09-25 15:44:42.000000000 +0200
++++ linux-2.6.22/drivers/video/pxafb.h 2007-09-25 15:45:07.000000000 +0200
+@@ -36,7 +36,7 @@
+       struct fb_bitfield      transp;
+ };
+-#ifdef CONFIG_PXA27x
++#if defined(CONFIG_PXA27x) || defined(CONFIG_PXA3xx)
+ /* PXA Overlay Framebuffer Support */
+ struct overlayfb_info
+ {
+@@ -142,7 +142,7 @@
+       wait_queue_head_t       ctrlr_wait;
+       struct work_struct      task;
+-#ifdef CONFIG_PXA27x
++#if defined(CONFIG_PXA27x) || defined(CONFIG_PXA3xx)
+       /* PXA Overlay Framebuffer Support */
+       struct overlayfb_info  *overlay1fb;
+       struct overlayfb_info  *overlay2fb;
index c1883800b524fbeb8dd32fcd8813dfb3fac6a2d1..8a981f4e7243723689c3157cd6327a695cca13e6 100644 (file)
@@ -1,6 +1,6 @@
 require linux-rp.inc
 
-PR = "r6"
+PR = "r7"
 
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_htcuniversal = "1"
@@ -122,6 +122,7 @@ SRC_URI_append_htcuniversal ="\
 
 SRC_URI_append_zylonite ="\
        file://arm_pxa_20070923.patch;patch=1 \
+       file://pxa_fb_overlay.patch;patch=1 \
        file://irq-gpio-offby1.patch;patch=1 \
        file://zylonite-boot.patch;patch=1 \
        "