]> code.ossystems Code Review - openembedded-core.git/commitdiff
connman-conf: configures connman in qemu machines
authorCristian Iorga <cristian.iorga@intel.com>
Tue, 15 Jan 2013 20:08:46 +0000 (22:08 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Jan 2013 11:54:44 +0000 (11:54 +0000)
For qemu machines, connman should not configure
virtual wired interfaces. Wired interfaces (eth0)
are assigned static IP addresses by the virtual machine
manager (qemu). This packages places the eth0 interface in
a list of blacklisted interfaces, forbiding connman
administering wired interfaces for qemu machines.

Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/conf/layer.conf
meta/recipes-connectivity/connman/connman-conf.bb [new file with mode: 0644]
meta/recipes-connectivity/connman/connman-conf/qemuall/main.conf [new file with mode: 0644]

index 78ceae9db6669012f158d786c8d45ec860c8001c..3259e5c712b46ef016007dee6900e072f76e96a2 100644 (file)
@@ -22,6 +22,7 @@ SIGGEN_EXCLUDERECIPES_ABISAFE += " \
   shadow-securetty \
   opkg-config-base \
   netbase \
+  connman-conf \
   formfactor \
   xserver-xf86-config \
   pointercal \
diff --git a/meta/recipes-connectivity/connman/connman-conf.bb b/meta/recipes-connectivity/connman/connman-conf.bb
new file mode 100644 (file)
index 0000000..7c7ef26
--- /dev/null
@@ -0,0 +1,18 @@
+#connman config to ignore wired interfaces on qemu machines
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI_append_qemuall = " file://main.conf"
+
+PR = "r0"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_install() {
+    #Blacklist ethn network interface in case of qemu* machines
+    if test -e ${WORKDIR}/main.conf; then
+        install -d ${D}${sysconfdir}/connman
+        install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
+    fi
+}
diff --git a/meta/recipes-connectivity/connman/connman-conf/qemuall/main.conf b/meta/recipes-connectivity/connman/connman-conf/qemuall/main.conf
new file mode 100644 (file)
index 0000000..01973e7
--- /dev/null
@@ -0,0 +1,3 @@
+[General]
+
+NetworkInterfaceBlacklist = eth