]> code.ossystems Code Review - openembedded-core.git/commitdiff
libsdl2: allow to build native and nativesdk
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 13 Sep 2017 10:57:35 +0000 (12:57 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 22 May 2018 12:09:02 +0000 (13:09 +0100)
* enable x11 in native builds

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb

index c0cf70d7fd026efc36e1c7a8006e6615ae66f369..c37f6693218f7590263b01605efc2cf5e8095b40 100644 (file)
@@ -37,6 +37,8 @@ EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
 # and BSP layers to pick either (desktop) opengl, gles2, or no GL
 PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
 
+PACKAGECONFIG_class-native = "x11"
+PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
 PACKAGECONFIG ??= " \
     ${PACKAGECONFIG_GL} \
     ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \
@@ -63,3 +65,5 @@ do_configure_prepend() {
 }
 
 FILES_${PN}-dev += "${libdir}/cmake"
+
+BBCLASSEXTEND = "native nativesdk"