]> code.ossystems Code Review - openembedded-core.git/commitdiff
vim: Clarify where RDEPENDS/RRECOMMENDS apply
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 2 Aug 2021 15:37:03 +0000 (16:37 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 2 Aug 2021 15:41:51 +0000 (16:41 +0100)
The tricky of using BPN in a common inc file is rather hard to understand.
Simplfy this by moving it to the base vim recipe and use the standard
variable form.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/vim/vim.inc
meta/recipes-support/vim/vim_8.2.bb

index 9e4117466e0f1f95b573389b2809b3dbe2f1aa92..17d1c24a7cc7bead334c4284e734487e8a3e0cfb 100644 (file)
@@ -140,10 +140,6 @@ FILES:${PN}-common = " \
     ${datadir}/icons \
 "
 
-RDEPENDS:${BPN} = "ncurses-terminfo-base"
-# Recommend that runtime data is installed along with vim
-RRECOMMENDS:${BPN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
-
 ALTERNATIVE:${PN} = "vi vim"
 ALTERNATIVE_PRIORITY = "100"
 ALTERNATIVE_TARGET = "${bindir}/${BPN}.${BPN}"
index 3c1b98dca0814c2f089343c8258b8a2361fa10b0..f358e61132b3dd1418e41ff81a1836c19d2de428 100644 (file)
@@ -2,6 +2,10 @@ require vim.inc
 
 PROVIDES = "xxd"
 
+RDEPENDS:${PN} = "ncurses-terminfo-base"
+# Recommend that runtime data is installed along with vim
+RRECOMMENDS:${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
+
 PACKAGECONFIG:class-native = ""
 BBCLASSEXTEND = "native nativesdk"