]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-demos: Require X11 distro feature
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Mon, 18 Jul 2016 11:54:48 +0000 (14:54 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jul 2016 09:24:56 +0000 (10:24 +0100)
Mesa-demos theoretically does not require X11 (apart from xdemos/)
but reality is that every other binary requires glut. So:
 * 'non-glut' part of mesa-demos requires X11
 * current freeglut recipe also depends on X11

There is apparently wayland support in freeglut now: This recipe
should be modified when meta-oe freeglut recipe has that feature.

The change became necessary now because mesa no longer mistakenly
installs GL files when X11 is disabled (and mesa-demos configure
currently requires GL).

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb

index ee0bb020a3601ddeccc601b693ee47e7b6c303c7..fab0bdb2ee24d21a7c10088962a1b6d91c2aaa91 100644 (file)
@@ -24,10 +24,10 @@ SRC_URI[sha256sum] = "c173154bbd0d5fb53d732471984def42fb1b14ac85fcb834138fb9518b
 
 inherit autotools pkgconfig distro_features_check
 # depends on virtual/egl, virtual/libgl ...
-REQUIRED_DISTRO_FEATURES = "opengl"
+REQUIRED_DISTRO_FEATURES = "opengl x11"
 
 PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
-                  ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu glx', '', d)}"
+                  x11 glew glu glx"
 
 # The Wayland code doesn't work with Wayland 1.0, so disable it for now
 #${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"