]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix an bitbake RDEPENDS bug and add a hack to work around quilt-native issues (the...
authorRichard Purdie <richard@openedhand.com>
Mon, 13 Feb 2006 13:09:56 +0000 (13:09 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 13 Feb 2006 13:09:56 +0000 (13:09 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@275 311d38ba-8fff-0310-9ca6-ca027cbcb966

bitbake/bin/bitbake
openembedded/conf/bitbake.conf
openembedded/packages/quilt/quilt-native_0.42.bb

index b1fd76a4f16a0b6bfb3b308cd2674012bb97d717..f371bfe16598b6ed5d0a2b6cb44ec3806dcf61b6 100755 (executable)
@@ -655,6 +655,7 @@ class BBCooker:
         if (item == pn):
             rdepends += bb.utils.explode_deps(bb.data.getVar('RDEPENDS', the_data, True) or "")
             rdepends += bb.utils.explode_deps(bb.data.getVar('RRECOMMENDS', the_data, True) or "")
+            rdepends += bb.utils.explode_deps(bb.data.getVar("RDEPENDS_%s" % pn, the_data, True) or "")
         else:
             packages = (bb.data.getVar('PACKAGES', the_data, 1).split() or "")
             for package in packages:
index 89ab4ff92407629413f002a6550a320da1a056e9..1b567fe5213a9ace6a602d5180cf0609dfa63f7d 100644 (file)
@@ -72,7 +72,7 @@ DATETIME = "${DATE}${TIME}"
 
 # python-native should be here but python relies on building 
 # its own in staging
-ASSUME_PROVIDED = "cvs-native svn-native"
+ASSUME_PROVIDED = "cvs-native svn-native bzip2-native patch-native diffstat-native"
 
 ##################################################################
 # Package default variables.
index ad3834ea216797b25db81ddf973987ae27d23439..6c54c476ce3976f862fb63d5c02c015d4101c262 100644 (file)
@@ -14,6 +14,9 @@ PATCHCLEANCMD = ""
 PATCHCMD = "num='%s'; name='%s'; file='%s'; patch -p "$num" -i "$file""
 EXTRA_OECONF = "--disable-nls"
 
+#RDEPENDS_${PN} = "patch-native diffstat-native bzip2-native"
+RDEPENDS_${PN} = ""
+
 do_configure () {
        chmod 755 configure
        oe_runconf