]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: Make it compatible with externalsrc
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Mon, 24 Sep 2018 19:03:13 +0000 (21:03 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2018 13:33:34 +0000 (14:33 +0100)
Fetch the test tar ball to a subdirectory in ${S}. This avoids the
following error after having done `devtool modify libxml2`:

| DEBUG: Executing shell function do_configure
| find: ‘.../build/tmp/work/mips32r2el-nf-poky-linux/libxml2/2.9.4-r0/xmlconf/’: No such file or directory

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/libxml/libxml2_2.9.8.bb

index d35f60832af8bd2949fc8dbd5164b2d0f56feeed..740bf56a5af8d22767eb11ad70d2c65378499b2f 100644 (file)
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
 DEPENDS = "zlib virtual/libiconv"
 
 SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
-           http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \
+           http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
            file://libxml-64bit.patch \
            file://runtest.patch \
            file://run-ptest \
@@ -77,7 +77,7 @@ FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
 
 do_configure_prepend () {
        # executables take longer to package: these should not be executable
-       find ${WORKDIR}/xmlconf/ -type f -exec chmod -x {} \+
+       find ${S}/xmlconf/ -type f -exec chmod -x {} \+
 }
 
 do_compile_ptest() {
@@ -85,7 +85,7 @@ do_compile_ptest() {
 }
 
 do_install_ptest () {
-       cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
+       cp -r ${S}/xmlconf ${D}${PTEST_PATH}
        if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
                sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
                    ${D}${PTEST_PATH}/python/tests/Makefile