]> code.ossystems Code Review - openembedded-core.git/commitdiff
tar: filter CVEs using vendor name
authorRalph Siemsen <ralph.siemsen@linaro.org>
Tue, 14 Sep 2021 19:15:47 +0000 (15:15 -0400)
committerAnuj Mittal <anuj.mittal@intel.com>
Tue, 26 Oct 2021 00:45:11 +0000 (08:45 +0800)
Recently a number of CVEs have been logged against a nodejs project
called "node-tar". These appear as false positives against the GNU tar
being built by Yocto. Some of these have been manually excluded using
CVE_CHECK_WHITELIST.

To avoid this problem, use the vendor name (in addition to package name)
for filtering CVEs. The syntax for this is:
  CVE_PRODUCT = "vendor:package"
When not specified, the vendor defaults to "%" which matches anything.

Signed-off-by: Ralph Siemsen <ralph.siemsen@linaro.org>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
(cherry picked from commit 45d1a0bea0c628f84a00d641a4d323491988106f)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-extended/tar/tar_1.34.bb

index 3488a6c955b8698eeaa3b7f720d1ca968f135da8..5a415c775a3059e6de1bc897f52dea9f74a30643 100644 (file)
@@ -63,6 +63,6 @@ NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
 
 BBCLASSEXTEND = "native nativesdk"
 
-# These are both specific to the NPM package node-tar
-CVE_CHECK_WHITELIST += "CVE-2021-32803 CVE-2021-32804"
-CVE_CHECK_WHITELIST += "CVE-2021-37701 CVE-2021-37712 CVE-2021-37713"
+# Avoid false positives from CVEs in node-tar package
+# For example CVE-2021-{32803,32804,37701,37712,37713}
+CVE_PRODUCT = "gnu:tar"