]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkit: updated to r31859 and disabled SVG fonts
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 14 Apr 2008 09:52:55 +0000 (09:52 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 14 Apr 2008 09:52:55 +0000 (09:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4246 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/poky.conf
meta/packages/webkit/files/GNUmakefile.am
meta/packages/webkit/files/autogen.sh [changed mode: 0644->0755]
meta/packages/webkit/files/configure.ac
meta/packages/webkit/webkit-gtk_svn.bb

index 0dc851bfeda267f3ff2244aa70059bb7d3a10e64..a88407f56802ce8f1715f31476132a70bef927a6 100644 (file)
@@ -142,7 +142,7 @@ SRCREV_pn-gaku ?= "365"
 SRCREV_pn-gypsy ?= "39"
 SRCDATE_yaffs2-utils = "20071107"
 SRCDATE_yaffs2-utils-native = "20071107"
-SRCREV_pn-webkit-gtk ?= "31467"
+SRCREV_pn-webkit-gtk ?= "31859"
 SRCREV_pn-clipboard-manager ?= "14994"
 SRCREV_pn-opkg ?= "4209"
 SRCREV_pn-opkg-native ?= "4209"
index 4cdd3dbfeb2a0e1fe93068880d0efbb776ab59a4..a0aefbf50b49f4915bdea6feb0d24046c66095ca 100644 (file)
@@ -116,13 +116,13 @@ libJavaScriptCore_la_CXXFLAGS = \
        $(global_cflags) \
        $(GLOBALDEPS_CFLAGS) \
        $(UNICODE_CFLAGS) \
-       -fstrict-aliasing
+       -fno-strict-aliasing
 
 libJavaScriptCore_la_CFLAGS = \
        $(global_cflags) \
        $(GLOBALDEPS_CFLAGS) \
        $(UNICODE_CFLAGS) \
-       -fstrict-aliasing
+       -fno-strict-aliasing
 
 libJavaScriptCore_la_CPPFLAGS = \
        $(global_cppflags) \
old mode 100644 (file)
new mode 100755 (executable)
index 64f32dc689757de0dc1c3ae253c72993c3de3488..3ab2baffb8b75ad473386787af8c8661e2840029 100644 (file)
@@ -263,11 +263,19 @@ AC_ARG_ENABLE(cross_document_messaging,
               [],[enable_cross_document_messaging="yes"])
 AC_MSG_RESULT([$enable_cross_document_messaging])
 
+# check whether to enable HTML5 client-side session and persitent storage support
+AC_MSG_CHECKING([whether to enable HTML5 client-side session and persistent storage support])
+AC_ARG_ENABLE(dom_storage,
+              AC_HELP_STRING([--enable-dom-storage],
+                             [enable HTML5 client-side session and persistent storage support [default=no]]),
+              [],[enable_dom_storage="no"])
+AC_MSG_RESULT([$enable_dom_storage])
+
 # check whether to build with database support
-AC_MSG_CHECKING([whether to enable HTML5 client-side storage support])
+AC_MSG_CHECKING([whether to enable HTML5 client-side database storage support])
 AC_ARG_ENABLE(database,
               AC_HELP_STRING([--enable-database],
-                             [enable HTML5 client-side storage support [default=yes]]),
+                             [enable HTML5 client-side database storage support [default=yes]]),
               [],[enable_database="yes"])
 AC_MSG_RESULT([$enable_database])
 
@@ -498,6 +506,7 @@ AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
 # WebKit feature conditionals
 AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
 AM_CONDITIONAL([ENABLE_CROSS_DOCUMENT_MESSAGING],[test "$enable_cross_document_messaging" = "yes"])
+AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
 AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
 AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
 AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
@@ -526,27 +535,28 @@ echo "
 WebKit was configured with the following options:
 
 Build configuration:
- Enable debugging (slow)           : $enable_debug
- Code coverage support             : $enable_coverage
- Unicode backend                   : $unicode_backend
- HTTP backend                      : $with_http_backend
- Font backend                      : $with_font_backend
- Optimized memory allocator        : $enable_fast_malloc
+ Enable debugging (slow)                                  : $enable_debug
+ Code coverage support                                    : $enable_coverage
+ Unicode backend                                          : $unicode_backend
+ HTTP backend                                             : $with_http_backend
+ Font backend                                             : $with_font_backend
+ Optimized memory allocator                               : $enable_fast_malloc
 Features:
- HTML5 cross-document messaging    : $enable_cross_document_messaging
- HTML5 client-side storage support : $enable_database
- HTML5 video element support       : $enable_video
- Icon database support             : $enable_icon_database
- SVG support                       : $enable_svg
- SVG animation support             : $enable_svg_animation
- SVG filters support               : $enable_svg_filters
- SVG fonts support                 : $enable_svg_fonts
- SVG foreign object support        : $enable_svg_foreign_object
- SVG as image support              : $enable_svg_as_image
- SVG use element support           : $enable_svg_use_element
- XPATH support                     : $enable_xpath
- XSLT support                      : $enable_xslt
+ HTML5 cross-document messaging                           : $enable_cross_document_messaging
+ HTML5 client-side session and persistent storage support : $enable_dom_storage
+ HTML5 client-side database storage support               : $enable_database
+ HTML5 video element support                              : $enable_video
+ Icon database support                                    : $enable_icon_database
+ SVG support                                              : $enable_svg
+ SVG animation support                                    : $enable_svg_animation
+ SVG filters support                                      : $enable_svg_filters
+ SVG fonts support                                        : $enable_svg_fonts
+ SVG foreign object support                               : $enable_svg_foreign_object
+ SVG as image support                                     : $enable_svg_as_image
+ SVG use element support                                  : $enable_svg_use_element
+ XPATH support                                            : $enable_xpath
+ XSLT support                                             : $enable_xslt
 GTK+ configuration:
- GDK target                        : $with_target
- Hildon UI extensions              : $with_hildon
+ GDK target                                               : $with_target
+ Hildon UI extensions                                     : $with_hildon
 "
index c7a49fdd2f837ba9bac8c341c8590064461f47dc..2e7a0885c06933778fc4810aa5c14d05eaf52ff2 100644 (file)
@@ -4,7 +4,7 @@ SRCREV_FORMAT = "webcore-rwebkit"
 
 # Yes, this is wrong...
 PV = "0.1+svnr${SRCREV}"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "\
   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -27,7 +27,6 @@ inherit autotools pkgconfig
 EXTRA_OECONF = "\
                 --enable-debug=no \
                 --enable-svg \
-               --enable-svg-fonts \
                 --enable-icon-database=yes \
                "