]> code.ossystems Code Review - openembedded-core.git/commitdiff
Switch from ipkg-utils to opkg-utils
authorRichard Purdie <richard@openedhand.com>
Thu, 17 Jul 2008 21:34:57 +0000 (21:34 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 17 Jul 2008 21:34:57 +0000 (21:34 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4863 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/classes/package_ipk.bbclass
meta/classes/rootfs_ipk.bbclass
meta/conf/bitbake.conf
meta/conf/distro/poky.conf
meta/packages/meta/meta-toolchain.bb

index f6c71a250dcdd2ecdf59ac6df1ca2e911b695d53..790bba0fd0a4e7c764f972cd06b4c0c7fb253523 100644 (file)
@@ -49,7 +49,7 @@ python package_ipk_install () {
 
        if (not os.access(os.path.join(ipkdir,"Packages"), os.R_OK) or
                not os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),os.R_OK):
-               ret = os.system('ipkg-make-index -p %s %s ' % (os.path.join(ipkdir, "Packages"), ipkdir))
+               ret = os.system('opkg-make-index -p %s %s ' % (os.path.join(ipkdir, "Packages"), ipkdir))
                if (ret != 0 ):
                        raise bb.build.FuncFailed
                f = open(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),"w")
@@ -74,16 +74,16 @@ package_update_index_ipk () {
        fi
 
        touch ${DEPLOY_DIR_IPK}/Packages
-       ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
+       opkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
 
        for arch in $ipkgarchs; do
                if [ -e ${DEPLOY_DIR_IPK}/$arch/ ] ; then 
                        touch ${DEPLOY_DIR_IPK}/$arch/Packages
-                       ipkg-make-index -r ${DEPLOY_DIR_IPK}/$arch/Packages -p ${DEPLOY_DIR_IPK}/$arch/Packages -l ${DEPLOY_DIR_IPK}/$arch/Packages.filelist -m ${DEPLOY_DIR_IPK}/$arch/
+                       opkg-make-index -r ${DEPLOY_DIR_IPK}/$arch/Packages -p ${DEPLOY_DIR_IPK}/$arch/Packages -l ${DEPLOY_DIR_IPK}/$arch/Packages.filelist -m ${DEPLOY_DIR_IPK}/$arch/
                fi
                if [ -e ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/ ] ; then 
                        touch ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages
-                       ipkg-make-index -r ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -p ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -l ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages.filelist -m ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/
+                       opkg-make-index -r ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -p ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -l ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages.filelist -m ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/
                fi
        done
 }
@@ -280,10 +280,10 @@ python do_package_ipk () {
 
                os.chdir(basedir)
                ret = os.system("PATH=\"%s\" %s %s %s" % (bb.data.getVar("PATH", localdata, 1), 
-                                                          bb.data.getVar("IPKGBUILDCMD",d,1), pkg, pkgoutdir))
+                                                          bb.data.getVar("OPKGBUILDCMD",d,1), pkg, pkgoutdir))
                if ret != 0:
                        bb.utils.unlockfile(lf)
-                       raise bb.build.FuncFailed("ipkg-build execution failed")
+                       raise bb.build.FuncFailed("opkg-build execution failed")
 
                for script in ["preinst", "postinst", "prerm", "postrm", "control" ]:
                        scriptfile = os.path.join(controldir, script)
@@ -302,7 +302,7 @@ python () {
     import bb
     if bb.data.getVar('PACKAGES', d, True) != '':
         deps = (bb.data.getVarFlag('do_package_write_ipk', 'depends', d) or "").split()
-        deps.append('ipkg-utils-native:do_populate_staging')
+        deps.append('opkg-utils-native:do_populate_staging')
         deps.append('fakeroot-native:do_populate_staging')
         bb.data.setVarFlag('do_package_write_ipk', 'depends', " ".join(deps), d)
 }
index 7db2ecb2f11fb7e79015264ca1b1f9208811992f..5e8a9c720ce8896aa74821d3d057348cbbf220ae 100644 (file)
@@ -8,7 +8,7 @@
 ROOTFS_PKGMANAGE = "opkg opkg-collateral"
 ROOTFS_PKGMANAGE_BOOTSTRAP  = "run-postinsts"
 
-do_rootfs[depends] += "opkg-native:do_populate_staging ipkg-utils-native:do_populate_staging"
+do_rootfs[depends] += "opkg-native:do_populate_staging opkg-utils-native:do_populate_staging"
 do_rootfs[recrdeptask] += "do_package_write_ipk"
 
 IPKG_ARGS = "-f ${IPKGCONF_TARGET} -o ${IMAGE_ROOTFS}"
index d51f9d9e78bb88801b3be3e85a21e21e51133c88..49bb6f09647a1c48d7e774ece1e54a080d2600ee 100644 (file)
@@ -512,9 +512,9 @@ MKTEMPCMD = "mktemp -q ${TMPBASE}"
 
 export PATCH_GET="0"
 
-# Program to be used to build ipkg packages
+# Program to be used to build opkg packages
 
-IPKGBUILDCMD = "ipkg-build -o 0 -g 0"
+OPKGBUILDCMD = "opkg-build -o 0 -g 0"
 
 ##################################################################
 # Not sure about the rest of this yet.
index 2a6927371bc4912fbe85aced29002904774a4c08..99d20287bb0e91394d792b42e3506151964d1553 100644 (file)
@@ -112,6 +112,7 @@ EXCLUDE_FROM_WORLD_pn-libopensync-plugin-irmc-sync = "1"
 EXCLUDE_FROM_WORLD_pn-libopensync-plugin-file-sync = "1"
 # Needs python
 EXCLUDE_FROM_WORLD_pn-ipkg-utils = "1"
+EXCLUDE_FROM_WORLD_pn-opkg-utils = "1"
 # Needs gcc 3.x
 EXCLUDE_FROM_WORLD_pn-qemu = "1"
 # temporary
index de82cab7658678489d8047a1a84788b90d236f41..4a383293ba162ff7c17be4bb45b6d9d89fe13ebd 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "Meta package for building a installable toolchain"
 LICENSE = "MIT"
-DEPENDS = "opkg-native ipkg-utils-native fakeroot-native sed-native"
+DEPENDS = "opkg-native opkg-utils-native fakeroot-native sed-native"
 
 inherit sdk meta
 
@@ -58,7 +58,7 @@ do_populate_sdk() {
                        if [ -e $pkgnames ]; then
                                echo "Found $pkgnames"
                                cp $pkgnames ${SDK_OUTPUT2}/${prefix}/ipk/
-                               orig_pkg=`ipkg-list-fields $pkgnames | grep OE: | cut -d ' ' -f2`
+                               orig_pkg=`opkg-list-fields $pkgnames | grep OE: | cut -d ' ' -f2`
                                pkg_subdir=$arch${TARGET_VENDOR}${@['-' + bb.data.getVar('TARGET_OS', d, 1), ''][bb.data.getVar('TARGET_OS', d, 1) == ('' or 'custom')]}
                                mkdir -p ${SDK_OUTPUT2}/${prefix}/pkgdata/$pkg_subdir/runtime
                                cp ${STAGING_DIR}/pkgdata/$pkg_subdir/$orig_pkg ${SDK_OUTPUT2}/${prefix}/pkgdata/$pkg_subdir/