]> code.ossystems Code Review - openembedded-core.git/commitdiff
librsvg: Disable 64bit atomics on riscv32/mipsel in crossbeam
authorKhem Raj <raj.khem@gmail.com>
Sat, 6 Nov 2021 15:36:56 +0000 (08:36 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 7 Nov 2021 10:56:24 +0000 (10:56 +0000)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/librsvg/librsvg_2.52.3.bb

index 6c4850271dea5bcdbd3f6a10220df05888e45e2c..f1d1a8f9f49ba5e4884aea1b6bb2965f90d786d0 100644 (file)
@@ -39,7 +39,9 @@ export RUST_TARGET_PATH
 export RUST_TARGET = "${HOST_SYS}"
 
 RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
+RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
 RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
+RUSTFLAGS:append:riscv32 = " --cfg crossbeam_no_atomic_64"
 
 # rust-cross writes the target linker binary into target json definition without any flags.
 # This breaks here because the linker isn't going to work without at least knowing where