]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: fix lack of MAP_32BIT on 32bit machines
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 9 Aug 2007 14:02:59 +0000 (14:02 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 9 Aug 2007 14:02:59 +0000 (14:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2475 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/qemu/files/qemu-amd64-32b-mapping-0.9.0.patch
meta/packages/qemu/qemu_cvs.bb

index 8f5e9d8b4b6cdd5231d2dd3eed80efdb8ac664b5..d9303e3464394da414300aadf6234288803a61b7 100644 (file)
@@ -1,7 +1,17 @@
-diff -Naru qemu-snapshot-2007-07-01_05.orig/linux-user/mmap.c qemu-snapshot-2007-07-01_05/linux-user/mmap.c
---- qemu-snapshot-2007-07-01_05.orig/linux-user/mmap.c 2007-06-03 17:31:32.000000000 +0200
-+++ qemu-snapshot-2007-07-01_05/linux-user/mmap.c      2007-07-02 14:00:30.000000000 +0200
-@@ -234,7 +234,7 @@
+--- qemu.orig/linux-user/mmap.c
++++ qemu/linux-user/mmap.c
+@@ -29,6 +29,10 @@
+ //#define DEBUG_MMAP
++#ifndef MAP_32BIT
++#define MAP_32BIT 0
++#endif
++
+ /* NOTE: all the constants are the HOST ones, but addresses are target. */
+ int target_mprotect(target_ulong start, target_ulong len, int prot)
+ {
+@@ -234,7 +238,7 @@
              host_offset = offset & qemu_host_page_mask;
              host_len = len + offset - host_offset;
              host_start = (long)mmap(real_start ? g2h(real_start) : NULL,
@@ -10,7 +20,7 @@ diff -Naru qemu-snapshot-2007-07-01_05.orig/linux-user/mmap.c qemu-snapshot-2007
              if (host_start == -1)
                  return host_start;
              /* update start so that it points to the file position at 'offset' */
-@@ -388,7 +388,7 @@
+@@ -388,7 +392,7 @@
      int prot;
  
      /* XXX: use 5 args syscall */
index 740bf1258969a53f29390233975915aa0d77ea38..29d68438ae0435661a380f412e445bea38b2989e 100644 (file)
@@ -1,7 +1,7 @@
 LICENSE = "GPL"
 DEPENDS = "zlib"
 PV = "0.9.0+cvs${SRCDATE}"
-PR = "r2"
+PR = "r3"
 
 FILESDIR = "${WORKDIR}"