]> code.ossystems Code Review - openembedded-core.git/commitdiff
psplash: Add handling for rotated displays
authorRichard Purdie <richard@openedhand.com>
Wed, 28 Mar 2007 11:00:17 +0000 (11:00 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 28 Mar 2007 11:00:17 +0000 (11:00 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1399 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/psplash/files/psplash-init
meta/packages/psplash/psplash_svn.bb

index a966638074d855c66878ae2755c0e65e266ed4f4..e2c6bf8f5d06b9477b1e3e6d856de03e0de21c5e 100755 (executable)
@@ -12,5 +12,10 @@ done
 export TMPDIR=/mnt/.psplash
 mount tmpfs -t tmpfs $TMPDIR -o,size=40k
 
-/usr/bin/psplash &
+rotation=0
+if [ -e /etc/rotation ]; then
+       rotation=`cat /etc/rotation`
+fi
+
+/usr/bin/psplash --angle=$rotation &
 
index 5ac42f9ec740b385f03e9610083e96c71344e072..4066c6b3fb6f544b6fcff8c5cfbbff9d984c5820 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
 SECTION = "base"
 LICENSE = "GPL"
 PV = "0.0+svn${SRCDATE}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
            file://psplash-init"