]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: add shared library version info to libxml shared libraries
authorMatthew McClintock <msm@freescale.com>
Mon, 2 Jan 2012 22:05:16 +0000 (16:05 -0600)
committerSaul Wold <sgw@linux.intel.com>
Tue, 10 Jan 2012 05:51:50 +0000 (21:51 -0800)
This fixes an issue with RPM where it checks version imformation for
binaries linked against libxml and fails because it's missing info

| error: Failed dependencies:
|              libxml2.so.2(LIBXML2_2.6.0) is needed by fmc-0.9.7+2-r2.1.ppce500mc
|              libxml2.so.2(LIBXML2_2.4.30) is needed by fmc-0.9.7+2-r2.1.ppce500mc
| ERROR: Function 'do_rootfs' failed (see

Note: fmc is just an example recipe/name

Signed-off-by: Matthew McClintock <msm@freescale.com>
meta/recipes-core/libxml/libxml2/fix_version_info.patch [new file with mode: 0644]
meta/recipes-core/libxml/libxml2_2.7.8.bb

diff --git a/meta/recipes-core/libxml/libxml2/fix_version_info.patch b/meta/recipes-core/libxml/libxml2/fix_version_info.patch
new file mode 100644 (file)
index 0000000..77113ef
--- /dev/null
@@ -0,0 +1,23 @@
+Upstream-Status: Already upstream
+
+From 00819877651b87842ed878898ba17dba489820f0 Mon Sep 17 00:00:00 2001
+From: Daniel Veillard <veillard@redhat.com>
+Date: Thu, 04 Nov 2010 20:53:14 +0000
+Subject: Reactivate the shared library versionning script
+
+---
+diff --git a/configure.in b/configure.in
+index 59d0629..a1d2c89 100644
+--- a/configure.in
++++ b/configure.in
+@@ -84,7 +84,7 @@ else
+   esac
+ fi
+ AC_SUBST(VERSION_SCRIPT_FLAGS)
+-AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -z "$VERSION_SCRIPT_FLAGS"])
++AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -n "$VERSION_SCRIPT_FLAGS"])
+ dnl
+ dnl We process the AC_ARG_WITH first so that later we can modify
+--
+cgit v0.9.0.2
index 2fa246e1829733d02ca401291feb1f30cb84f504..0b6ce02b006af696078b76850b10cd463ee8b3cc 100644 (file)
@@ -1,6 +1,8 @@
 require libxml2.inc
 
-PR = "r4"
+PR = "r5"
+
+SRC_URI += "file://fix_version_info.patch"
 
 SRC_URI[md5sum] = "8127a65e8c3b08856093099b52599c86"
 SRC_URI[sha256sum] = "cda23bc9ebd26474ca8f3d67e7d1c4a1f1e7106364b690d822e009fdc3c417ec"