]> code.ossystems Code Review - openembedded-core.git/commitdiff
lighthttp: Use pkg-config for pcre dependency
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 May 2014 09:55:50 +0000 (10:55 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 28 May 2014 07:23:57 +0000 (08:23 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lighttpd/lighttpd/pkgconfig.patch [new file with mode: 0644]
meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb

diff --git a/meta/recipes-extended/lighttpd/lighttpd/pkgconfig.patch b/meta/recipes-extended/lighttpd/lighttpd/pkgconfig.patch
new file mode 100644 (file)
index 0000000..e395f92
--- /dev/null
@@ -0,0 +1,33 @@
+Use pkg-config for pcre dependency instead of -config script.
+
+Upstream-Status: Pending
+
+RP 2014/5/22
+
+
+Index: lighttpd-1.4.35/configure.ac
+===================================================================
+--- lighttpd-1.4.35.orig/configure.ac  2014-03-06 14:08:00.000000000 +0000
++++ lighttpd-1.4.35/configure.ac       2014-05-13 16:58:30.758471169 +0000
+@@ -309,16 +309,14 @@
+ AC_MSG_RESULT([$WITH_PCRE])
+ if test "$WITH_PCRE" != "no"; then
+-  AC_PATH_PROG(PCRECONFIG, pcre-config)
+-
+-  if test x"$PCRECONFIG" != x; then
+-    PCRE_LIB=`$PCRECONFIG --libs`
+-    CPPFLAGS="$CPPFLAGS `$PCRECONFIG --cflags`"
++  PKG_CHECK_MODULES(PCREPKG, [libpcre], [
++    PCRE_LIB=${PCREPKG_LIBS}
++    CPPFLAGS="$CPPFLAGS ${PCREPKG_CFLAGS}"
+     AC_DEFINE([HAVE_LIBPCRE], [1], [libpcre])
+     AC_DEFINE([HAVE_PCRE_H], [1], [pcre.h])
+-  else
++  ], [
+      AC_MSG_ERROR([pcre-config not found, install the pcre-devel package or build with --without-pcre])
+-  fi
++  ])
+ fi
+ AC_SUBST(PCRE_LIB)
index bcab7d1931d42f3008bcfc13d6ee754058fb1955..0acc37d94fe00c39eba86842ac4c82e0492c019d 100644 (file)
@@ -23,6 +23,7 @@ SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.t
         file://lighttpd.conf \
         file://lighttpd \
         file://lighttpd.service \
+        file://pkgconfig.patch \
         "
 
 SRC_URI[md5sum] = "f7a88130ee9984b421ad8aa80629750a"